Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#1093 closed defect (fixed)

update installer versions and URLs

Reported by: hamish Owned by: kalxas
Priority: critical Milestone: OSGeoLive6.5
Component: OSGeoLive Keywords: 6.5, installers
Cc: live-demo@…

Description

Hi,

before final release we need to make sure that the versions in load_mac_installers.sh and load_win_installers.sh are all up to date, and that all of the URLs work.

this is independent of and has to happen before the final cut based on how much free disc space there is in the full build: we need this data before we can do that cut.

thanks, Hamish

Change history (18)

comment:1 Changed 7 years ago by hamish

version numbers bumped to most recent & urls updated for those that needed it; but not well tested. Seeing that the ISO is a couple hundred MB bigger this time there may be some choices to be made when it comes time to see what actually fits on the full-dvd.

Hamish

comment:2 Changed 7 years ago by hamish

note we still have dead links from the main page on the mini, when the installer directories do not exist. we should figure out how to make that point to the web pages more gracefully.

Hamish

comment:3 Changed 7 years ago by kalxas

Priority: blockercritical

Thanks Hamish for updating the application list.

comment:4 Changed 7 years ago by kalxas

As suggested by Cameron, as a way to solve the 404 errors is:

  1. Create a simple web page that says: "The installers are not included in this smaller distribution"
  2. During our load_win(mac)_installers.sh we should remove this html page. This should be done since there is no new doc build from mini iso to full iso.

Thoughts?

comment:5 Changed 7 years ago by hamish

a good plan, my only addition to it would be to have that page provide a link to the live.osgeo.org website, which has some index.html pages there with a list of the various projects' download pages.

Hamish

comment:6 Changed 7 years ago by camerons

Added a fix as described above.

 ~/livedvd/gisvm/trunk$ svn commit -m"include an index.rst file in the Win|Mac Installer dir, remove if the installers exist" bin/build_full_iso.sh doc/en/index.rst  doc/WindowsInstallers/ doc/MacInstallers/ doc/en/index.rst 
 Sending        bin/build_full_iso.sh
 Adding         doc/MacInstallers
 Adding         doc/MacInstallers/index.rst
 Adding         doc/WindowsInstallers
 Adding         doc/WindowsInstallers/index.rst
 Sending        doc/en/index.rst
 Transmitting file data ....
 Committed revision 9981.

This fix needs to be tested, in particular, verify that the index.html files are removed in Win/Mac? installer dirs during the full iso build.

comment:7 Changed 7 years ago by kalxas

Priority: criticalnormal

Thanks Cameron for the fix. I have updated the download size for the final iso.

This is not critical/blocker anymore for RC state.

Angelos

comment:8 Changed 7 years ago by hamish

further updates and fixes in r10008, r10009.

comment:9 Changed 7 years ago by kalxas

Resolution: fixed
Status: newclosed

confirmed fixed in [10028]

comment:10 Changed 7 years ago by kalxas

Resolution: fixed
Status: closedreopened

full iso still has problems with the proposed fix

comment:11 Changed 6 years ago by camerons

Priority: normalcritical
Type: taskdefect

The current situation is that in the full iso, the index.html file in the Win/Mac? Downloads directory is not being removed as it should.

Options to try:

  1. At the start of the bin/build_full_iso.sh, remove the doc/WindowsInstallers/index.rst and doc/MacInstallers/index.rst source files.
  1. Retrospectively unpack the iso image, remove the index.html file, then repack the image.

comment:12 Changed 6 years ago by kalxas

Owner: changed from live-demo@… to kalxas
Status: reopenednew

comment:13 Changed 6 years ago by hamish

Cc: live-demo@… added

comment:14 Changed 6 years ago by kalxas

new fix committed in [10035]

comment:15 Changed 6 years ago by hamish

I don't know if it does any harm besides adding unneeded complexity, but there's no need to use chroot in making the full.iso, as it doesn't need to run anything- the file manifest re-run is not needed, as that only records files kept in the dpkg database, and no .deb packages within the disc were added or removed in the installer tweak, only to the hold system.

along similar does no harm besides adding unneeded complexity lines, does the script need to be run as a regular user or as root? (are the sudos needed?)

fwiw I'd suggest turning off the progress indicators to improve the signal to noise ratio in the logs,

mksquashfs ... -no-progress
mkisofs ... -quiet

note mksquashfs wants -no-progress as the final option on the command line.

final style critique is to suggest to set $USER_HOME instead of hardcoding /home/user as the other scripts. (again no harm to current build)

thanks, Hamish

comment:16 Changed 6 years ago by kalxas

Resolution: fixed
Status: newclosed

Hamish, chroot is not a big deal here since we removed the weird mounts.

Confirmed in [10039]

comment:17 Changed 6 years ago by hamish

It doesn't matter, but fwiw, the correct target would have been /cdrom/, as /media/cdrom/ is just a symlink to that.

comment:18 Changed 6 years ago by kalxas

I agree. Lets fix that on svn

Note: See TracTickets for help on using tickets.