Opened 6 years ago

Closed 6 years ago

#1031 closed defect (fixed)

Cartaro not installed properly

Reported by: kalxas Owned by: phaf
Priority: major Milestone: OSGeoLive6.5
Component: OSGeoLive Keywords: 6.5 alpha 4
Cc: live-demo@…

Description

Tested in 6.5 alpha4 and the launcher is creating a permission problem. When starting through "sudo" the script reports missing startup script.

Change history (8)

comment:1 Changed 6 years ago by phaf

Owner: changed from live-demo@… to phaf
Status: newassigned

comment:2 Changed 6 years ago by phaf

Permissions were only one side of the problems. Due to problems with Geoserver (we heavily depend on it) the whole installation simply failed in alpha4. We now fixed this issue and did some things more:

  • Removed documentation icon
  • Fixed permission for startup script
  • Introduced new way to install PostGIS
  • Fixed some more permission
  • Bumped to latest beta version

We successfully passed some internal test builds and continue testing the next days.

comment:3 Changed 6 years ago by kalxas

Resolution: fixed
Status: assignedclosed

Cartaro is now working on alpha 5 Thanks for your efforts.

comment:4 Changed 6 years ago by hamish

Cc: live-demo@… added
Resolution: fixed
Status: closedreopened

please move the ML email addr from the owner field if you take ownership of a ticket so it doesn't get lost

ps- "chmod a+w" is *not* a suitable solution for the DVD. rather use like:

"chmod g+w; chgrp users; adduser user users"

see many other scripts for examples, the "www-data" group may be more appropriate than "users" for web-accessible apps.

(reopening ticket)

comment:5 Changed 6 years ago by kalxas

Hamish,

Live session user belongs only in "user" group so the above fix you propose won't work for live session. Same applies to GeoServer?.

Angelos

comment:6 in reply to:  5 Changed 6 years ago by hamish

Replying to kalxas:

Live session user belongs only in "user" group so the above fix you propose won't work for live session. Same applies to GeoServer?.

? the same method is used in many scripts without problem for years.

Have a look in /etc/group or type groups at a command prompt; "user" belongs to the "users" group alright, along with audio, tomcat6, fuse, www-data, and others we'd miss if we weren't in them.

The settings in /etc/group survive the build_iso and build_chroot scripts, since they are referenced by name not number, so even when /etc/passwd and the user's UID and GID do not.

best, Hamish

comment:7 Changed 6 years ago by hamish

sudo stuff removed from Desktop icon and replaced with as-needed when-needed in the startup and shutdown scripts.

firefox was getting run as root and writing files as root to ~/.mozilla, so that you couldn't use firefox anymore as a regular user, since you didn't own the profile in your own home directory.

hopefully it's all ok in the next nightly build.

Hamish

comment:8 Changed 6 years ago by kalxas

Resolution: fixed
Status: reopenedclosed

fixed and confirmed in [9658]

Note: See TracTickets for help on using tickets.