wiki:OSGeo4W_jp/QGIS

QGIS

QGISの使用

  1. シェルウィンドウに 'qgis&' と入力し、QGISアプリケーションを開始してください。
  2. ツールバーの “Add a vector layer” をクリックしてください。
  3. /var/www/html/jica/data/ ディレクトリを参照します。
  4. “us_states.shp” ファイルを選択し、“オープン” ボタンをクリックします。(“us_urban_areas.shp” 、 “us_lakes.shp” および “us_interstate.shp”においても、同じ手順で行ってください)。レイヤーの順番が次のようにならない場合、望む位置にドラッグ・アンド・ドロップすることでそれぞれのレイヤーを並び替えることができます。
上位レイヤー
us_interstate.shp
us_urban_areas.shp
us_states.shp
下位レイヤー
  1. “us_states” レイヤーを右クリックし、“プロパティ” を選択します。サンプルから任意の塗りつぶしの色、輪郭の色を選びます。“適用” をクリックし、“OK” ボタンをクリックします。他のレイヤーも同じ方法で色をつけることができます。

  1. 凡例リストの“us_urban_areas”レイヤーを選択します。
  2. “us_urban_areas”レイヤーをズームするには、ツールバーメニューのをクリックします。
  3. “ファイル->プロジェクトを保存” を選択し,“usstate.qgs”と名前を付けて保存してください。
  4. メニューバーから “File->Export to MapServer Map...”を選択します。そして、以下のように編集してください。
    • "別名で保存" を選択し、/var/www/html/jica/mapfile/ を参照します。
    • "uslayer.map" とファイル名をつけて、"保存" ボタンをクリックします。
    • QGIS Project ファイルを参照するため、"参照" を選択します[usstate.qgs]。
    • マップテキストボックスに "usstate" と入力します。
    • 幅テキストボックスに "525" と入力します。
    • 高さテキストボックスに "450" と入力します。
    • 画像タイプリストボックスから "png" を選択します。
  5. "OK" をクリックし、エクスポートしてください。
  6. 凡例リストの “us_states” 以外のチェックを外します。
  7. メニューバーから “ファイル->イメージで保存” を選択し、/var/www/html/jica/mapfile/ を参照してください。
  8. “keyus.jpg” とファイル名を付け、ファイルの種類から “JPEG format” を選択し、 “Save” をクリックします。
  9. Kwriteエディターを使用して、uslayerマップファイル(/var/www/html/jica/mapfile/uslayer.map)およびテンプレートマップファイル(/var/www/html/jica/mapfile/template.map)を開いてください。
  10. “template.map” ファイルのコンテンツをコピーして “UNITS dd” の下のラインへ “usstate.map” を挿入し、 “usstate.map” とファイル名を付けて保存します。
  11. REFERENCEの部分に進み、以下のように編集してください。
    • REFERENCEの “EXTENT” の部分を “ -168.918705 -10.135221 -63.515576 94.183142” に書き換えてください。
    • REFERENCEの “IMAGE” の部分を “keyus.jpg” に書き換えてください。
    • “keyus.jpg” 画像のサイズを変更するため、 “GIMP” ソフトウェアあるいは他の画像処理を使用してください。
    • REFERENCEの “SIZE” の部分を “158 136” に書き換えてください。
  12. “#Background color for the map canvas...” に進み、以下のように編集してください。
    • “IMAGECOLOR” の部分を “255 255 255” に書き換えてください。
    • “IMAGEPATH” の部分を “/tmp/” から “/var/www/html/tmp/ms_tmp/” に書き換えてください。
    • “IMAGEURL” の部分を “tmp/” を “/tmp/ms_tmp” に書き換えてください。
    • “wms_onlineresource” の部分を下記の通りに書き換えてください(WMSサーバーを有効にします)。
      • from:http://my.host.com/cgi-bin/mapserv?map=wms.map
      • to:http://<ip>/cgi-bin/mapserv?map=/var/www/html/jica/mapfile/usstate.map
        注意:<ip> の部分を下記のシェルウィンドウのコマンドのように、自分のipアドレスあるいはドメイン名に変更しなければなりません。
      • コマンド  
        /sbin/ifconfig
        
  13. このマップファイルの画像マップは、下記のシェルウィンドウのコマンドを入力することで、shp2imgツールによって作成されるでしょう。
    • コマンド
      /var/www/cgi-bin/shp2img-m/var/www/html/jica/mapfile/usstate.map–o/tmp/test.png
      
  14. File Explorerを開き、/tmp/ を参照します。“test.png” ファイルをクリックし、画像マップをプレビューしてください。

注意:QGIS functionによってエクスポートされたRGB値はQGISアプリケーションに同じように表示されないこともあります。しかし、正確な値は“Properties->Symbology->Fill color” から確認され、マップファイルのRGB値を編集します。

  1. Mozilla Firefoxブラウザーで次のURLを開き、GetCapabilitiesを試してください。

URL:http://localhost/cgi-bin/mapserv?map=/var/www/html/jica/mapfile/usstate.map&Service=WMS&Request=GetCapabilities

  1. xmlファイルを保存するために、ダイアログボックスが表示されます。保存してください。
  2. Openファイルをクリックし、XMLドキュメントを確認してください。
  3. Kwriteを開き、下記のコンテンツを入力してください。
#!/bin/sh
export MS_MAPFILE=/var/www/html/jica/mapfile/usstate.map
./mapserv
  1. /home/grass ディレクトリに “usstate” と名前を付けて保存します。
  2. /var/www/cgi-bin/ へ “usstate” をコピーし、シェルウィンドウの次のコマンドを実行するために許可を設定してください。
su
cp /home/grass/usstate/ var/www/cgi-bin/
chmod a+x /var/www/cgi-bin/usstate
  1. Kwriteを使用して “usstate.map” を開き、“wms_onlineresource” の部分を次のように置き換えます(WMSサーバーを有効にします)。
from:‘http://<ip>/cgi-bin/mapserv?map=/var/www/html/jica/mapfile/usstate.map’
to:‘http://<ip>/cgi-bin/usstate?’

注意:<ip> の部分を自分のipアドレスあるいはドメイン名に変更しなければなりません。

  1. 編集したマップファイルを保存します[usstate.map]。
  2. Mozilla Firefox ブラウザーで次のURLを開きGetCapabilitiesを試してください。
    URL:http://localhost/cgi-bin/usstate?Service=WMS&Request=GetCapabilities
  1. xmlファイルを保存するためにダイアログボックスが表示されます。保存してください。
  2. Openファイルをクリックし、XMLドキュメントを確認してください。

QGISでOpenStreetMapベトナムデータ使用する

  • 《すべてのプログラム》、またはOSGeo4WコマンドラインからQGISを起動します。
  • トレーニングCDからベトナムのベクトルレイヤーを追加してください。
  • レイヤー上で右クリックして追加されたレイヤーを合わせ、《プロパティ》に進みます。
  • 《シンボルタブ》から適切な色、輪郭の色、パターンを選択します。
  • よければOKをクリックします。
  • 《 yourproject.qgs 》と名前を付けてQGIS projectを保存してください。

QGIS ですぐにマップファイルを作成する

Quantum GIS(QGIS)はGNU General Public Licenseの下で認可されたユーザーに優しいOpen Source Geographic Information System(GIS)です。QGISはOpen Source Geospatial Foundation(OSGeo)の公式プロジェクトです。それはLinux、Unix、Mac OSX、Winowsで実行でき、多数のベクトル、ラスターおよびデータベースフォーマットや機能性をサポートしています。

Quantum GISは主要の機能やプラグインによって提供された継続的に増えている機能を提供しています。視覚化、管理、編集、データ分析、印刷可能なマップの作成ができます。スクリーンショットや詳細リストを見てイメージしてください。

MapServer Export C plugin は、ジョブの最大のパートが自動的になされるので、より速くマップファイルを作成するのにとても便利です。

MapServer Export Pluginの使用

  • MapServer Export Pluginを起動します。
  • 《 yourproject.qgs 》を参照します。
  • パスとエクスポートしたいマップファイル名を選択します。
  • 他の設定を調整します(マップ名、サイズ、画像タイプ、マップユニット)
  • いくつかの記号とフォントファイルを参照します(任意)。
  • OKをクリックします。
  • マップファイルは正常にエクスポートされました、というメッセージウィンドウが表示されます。
Last modified 8 years ago Last modified on May 17, 2010 7:36:04 PM