Opened 3 years ago

Closed 3 years ago

#3565 closed bug (fixed)

Popup has offset in the latest version

Reported by: sangzier Owned by: euzuro
Priority: critical Milestone: 2.12 Release
Component: Popup Version: 2.11
Keywords: Cc:
State:

Description

We used openlayers with popup functions works fine without offset before Nov 1st, 2011 on OpenLayers-2.11-rc1 version. But suddenly not working anymore. I have tried both OpenLayers-2.11-rc1 and latest version OpenLayers-2.11, both has big offsets with popups.

Please check the snapshots as attached.

Attachments (2)

icon position without popup.JPG (22.2 KB) - added by sangzier 3 years ago.
Icon is in the right position
icon with popup.JPG (36.2 KB) - added by sangzier 3 years ago.
When you click the icon, popup will open, but the arrow will point the wrong place, with offset to the icon position, actually icon was hidden by the popup body

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by sangzier

Icon is in the right position

Changed 3 years ago by sangzier

When you click the icon, popup will open, but the arrow will point the wrong place, with offset to the icon position, actually icon was hidden by the popup body

comment:1 in reply to: ↑ description Changed 3 years ago by sangzier

Replying to sangzier:

We used openlayers with popup functions works fine without offset before Nov 1st, 2011 on OpenLayers-2.11-rc1 version. But suddenly not working anymore. I have tried both OpenLayers-2.11-rc1 and latest version OpenLayers-2.11, both has big offsets with popups.

Please check the snapshots as attached.

_

Add more info, I found this issue just happens when you put the map window in a iframe, the position will have offset as I said before. How do we fix it?

comment:2 Changed 3 years ago by sangzier

  • Resolution set to fixed
  • Status changed from new to closed

This issue is caused by the latest Chorme browser. Please check the below link: http://code.google.com/p/chromium/issues/detail?id=88742

Note: See TracTickets for help on using tickets.