Ticket #1528 (closed feature: duplicate)

Opened 6 years ago

Last modified 6 years ago

in WFS-T (update and remove), the attribute 'typename' is not properly set.

Reported by: xculos Owned by: tschaub
Priority: minor Milestone:
Component: Format.WFS Version: 2.6
Keywords: wfs wfs-t typename Cc:
State: Needs More Work

Description

In generated XML for WFS-T, the attribute typeName of the tag Update (or Delete) is set to 'features' while the parameter of the layer say : { typename: "cities"}

<wfs:Transaction xmlns:wfs="http://www.opengis.net/wfs" version="1.0.0" service="WFS"><wfs:Update typeName="features">

in OpenLayers.Format.WFS, the code uses 'layerName' property in place of featureName ?

in OpenLayers.Layer.WFS.initialize, 'this.options.typename' is never set. the this.params = params; assignment may be made before ?

Change History

Changed 6 years ago by bartvde

  • status changed from new to closed
  • resolution set to duplicate

This is a duplicate of ticket:1471

Note: See TracTickets for help on using tickets.