Opened 12 years ago

Closed 12 years ago

#502 closed defect (duplicate)

[WMS server]Service exception not returned for an invalid layer name

Reported by: nsavard@… Owned by: mapserverbugs
Priority: high Milestone:
Component: WMS Server Version: 4.1
Severity: normal Keywords:
Cc:

Description

Service exception not returned for an invalid layer name when a GetMap is
issued.  The request sent contains two layer:  one is valid and the second is
not valid.  This code "LayerNotDefined" must be include into the service
exception document.

Test:
wms/wmsops/getmap/params/layers/6

URL request sent:
http://www2.dmsolutions.ca/cgi-bin/mswms_ogc_cite?LaYeRs=Lakes,NonExistant&VeRsIoN=1.1.1&FoRmAt=image/gif&ReQuEsT=GetMap&WiDtH=168&BbOx=-0.0042,-0.0024,0.0042,0.0024&HeIgHt=96&StYlEs=&SrS=EPSG:4326

Change History (2)

comment:1 Changed 12 years ago by nsavard@…

There are two OGC Cite WMS tests reladed to this bug.  The test indicated in
this bug and the test "wms/wmsops/getmap/params/layers/7".  This test (7) is
almost identical to the test "wms/wmsops/getmap/params/layers/6".  The request
contains two layer names in which the first is not valid and the second is valid.

comment:2 Changed 12 years ago by nsavard@…

  • Resolution set to duplicate
  • Status changed from new to closed

*** This bug has been marked as a duplicate of 400 ***
Note: See TracTickets for help on using tickets.