Opened 12 years ago

Closed 12 years ago

#499 closed defect (duplicate)

Can't have a layer with LABEL but no STYLE component.

Reported by: jlacroix Owned by: sdlime
Priority: high Milestone:
Component: MapServer C Library Version: 4.0
Severity: normal Keywords:
Cc:

Description

 

Change History (5)

comment:1 Changed 12 years ago by jlacroix

  • Owner changed from sdlime to morissette@…
This problem occurs on both mapscript and CGI (mapserver 4.0).

I have a test mapfile with only one layer in it. This layer contains a CLASS,
with a LABEL, but no STYLE components. When I try to draw the map, the cgi
returns a blank page and mapscript return false when calling draw(). In both
cases, no error message are processed. 

A turn around is to put an empty STYLE object or the parameter "COLOR -1 -1 -1"
in the CLASS.

comment:2 Changed 12 years ago by sdlime

  • Status changed from new to assigned
Hmmm... Easy enough to reproduce. I thought there were 2 default styles (they 
map to the base and overlay symbols in older versions), but perhaps they're 
only created as needed.

comment:3 Changed 12 years ago by dmorissette

  • Cc mapserver-bugs@… added
  • Owner changed from morissette@… to sdlime
  • Status changed from assigned to new
Reassigned to Steve

comment:4 Changed 12 years ago by dmorissette

  • Status changed from new to assigned

comment:5 Changed 12 years ago by sdlime

  • Resolution set to duplicate
  • Status changed from assigned to closed

*** This bug has been marked as a duplicate of 495 ***
Note: See TracTickets for help on using tickets.