Opened 13 years ago

Closed 10 years ago

#1976 closed defect (fixed)

Optimize lookup of EPSG projection codes

Reported by: dmorissette Owned by: dmorissette
Priority: high Milestone: 5.4 release
Component: WMS Server Version: unspecified
Severity: normal Keywords: projections
Cc: warmerdam, jmckenna

Description (last modified by dmorissette)

A few weeks ago I was doing some benchmarks with MapServer 4.10 on a mapfile
with about 10 layers in it and replacing the 10 "init=epsg:xxxx" defns with
native PROJ.4 definitions made the WMS GetCapabilities requests go from 3
hits/seconds to 12 hits/seconds (4 times faster!).

Since EPSG codes are used a lot by all OGC services, optimizing the EPSG lookup
(or caching them at a minimum) is something that would be very valuable for all
OGC service users.

Change History (12)

comment:1 Changed 13 years ago by dmorissette

Milestone: 5.0 release
Owner: changed from mapserverbugs to dmorissette
Let's see if we can address this in 5.0

comment:2 Changed 13 years ago by dmorissette

Summary: Optimize parsing of EPSG projecion codesOptimize lookup of EPSG projection codes

comment:3 Changed 12 years ago by dmorissette

Cc: warmerda added
Description: modified (diff)

comment:4 Changed 12 years ago by dmorissette

Cc: warmerdam added; warmerda removed

comment:5 Changed 12 years ago by dmorissette

Status: newassigned

Ticket #1426 was marked as duplicate of this ticket.

comment:6 Changed 12 years ago by dmorissette

I have started a thread discussing possible solutions on the PROJ list: http://lists.maptools.org/pipermail/proj/2007-August/003002.html

comment:7 Changed 12 years ago by hobu

This one isn't happening for 5.0, right?

comment:8 Changed 12 years ago by dmorissette

Depending on the outcome of the discussion on the PROJ list the issue may be fixed in 5.0 with very little or no changes to the code, it may end up only being a documentation issue (e.g. use PROJ v x.y with threads option enabled) so I'll wait until the last minute before pusing this to 5.2.

comment:9 Changed 12 years ago by dmorissette

Milestone: 5.0 release5.2 release

comment:10 Changed 11 years ago by jmckenna

Cc: jmckenna added

comment:11 Changed 11 years ago by dmorissette

Milestone: 5.2 release5.4 release

comment:12 Changed 10 years ago by warmerdam

Keywords: projections added
Resolution: fixed
Status: assignedclosed

I have added memory caching of init definitions in PROJ.4, primarily in:

http://trac.osgeo.org/proj/changeset/1542

This should appear in the PROJ 4.7.0 release in the fairly near future I hope.

Note: See TracTickets for help on using tickets.