wiki:2.1MigrationInstructions

Upgrading to MapGuide Open Source 2.1 From an Earlier Release

To upgrade from an earlier release of MapGuide Open Source, the repositories must be upgraded.

Windows

  1. Stop the earlier release of the MapGuide Open Source Server if it is running. To do this, open the Services applet. Select “MapGuide Open Source Server”, and then select Action > Stop.
  2. Open a DOS window and change to the RepositoryAdmin subdirectory of the server install location.
  3. In the DOS window, run BackUpOfflineRepositories.bat. Check the output to make sure there are no errors.
  4. In the DOS window, run RestoreColdBackupRepositories.bat. Check the output to make sure there are no errors.
  5. Install the 2.1 server.
  6. Stop the newly installed server if it is running.
  7. Delete the Repositories subdirectory of the 2.1 server.
  8. Copy the the old Repositories subdirectory of the old server to the 2.1 server.
  9. In the DOS window, change to the RepositoryAdmin subdirectory of the 2.1 server.
  10. In the DOS window, run UpgradeRepositories.bat. Check the output to make sure there are no errors.
  11. In the DOS window, run SetupRepositoryIndices.bat. Check the output to make sure there are no errors.
  12. Start your 2.1 server.

Linux

  1. Stop the earlier release of the MapGuide Open Source Server if it is running.
  2. Open a shell and change to the RepositoryAdmin subdirectory of the server install location.
  3. Run BackUpOfflineRepositories.sh. Check the output to make sure there are no errors.
  4. Run RestoreColdBackupRepositories.sh. Check the output to make sure there are no errors.
  5. Install the 2.1 server.
  6. Stop the newly installed server if it is running.
  7. Delete the Repositories subdirectory of the 2.1 server.
  8. Copy the the old Repositories subdirectory of the old server to the 2.1 server.
  9. In the shell change to the RepositoryAdmin subdirectory of the 2.1 server.
  10. Run UpgradeRepositories.sh. Check the output to make sure there are no errors.
  11. Run SetupRepositoryIndices.sh. Check the output to make sure there are no errors.
  12. Start your 2.1 server.
Last modified 9 years ago Last modified on May 26, 2009 12:34:05 PM