Opened 10 years ago

Closed 10 years ago

#887 closed defect (fixed)

mod_mgmapagent.so (built from svn) will not load in Apache

Reported by: jng Owned by:
Priority: high Milestone: 2.1
Component: Map Agent Version:
Severity: blocker Keywords:
Cc: jng, jbirch External ID:

Description

When attempting to run Apache using the web extensions built from svn trunk, it will error out with the following message:

httpd.exe: Syntax error on line 195 of C:/Program Files/OSGeo/MapGuide Web/Apache2/conf/httpd.conf: Cannot load C:/Program Files/OSGeo/MapGuide Web/Apache2/modules/mod_mgmapagent.so into server: This application has failed to start because the application configuration is incorrect. Reinstalling this application may fix this problem.

The message sounds remotely familiar to something that the Visual C++ CRT would throw out. I did a depends.exe on mod_mgmapagent.so and I have found references to Visual C++ 2005 CRT dlls (MSVCP80.dll and MSVCR80.dll). The code-base has moved to VS 2008 so maybe these references should not be there?

I am blocker-izing this issue because this error prevents us from having a functional Apache configuration for the community-based installer.

Attachments (1)

mod_mgmapagent.so (54.0 KB) - added by tomfukushima 10 years ago.
Release version of module using 90 versions of the DLLs

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by tomfukushima

Hi Jackie, If you build the mod_mgmapagent.so using VS 2008 it will reference the correct DLLs. The project to build it is the ApacheAgent? project in the WebTier? solution. I'm pretty sure of this because the one that I have built only references msvcp90.dll and msvcr90.dll.

Changed 10 years ago by tomfukushima

Attachment: mod_mgmapagent.so added

Release version of module using 90 versions of the DLLs

comment:2 Changed 10 years ago by jng

Hi Tom, this apache module works! I'm wondering why the mod_mgmapagent.so I built has VS 2005 CRT references. I do have VS 2005 and VS 2008 running side-by-side, could this be the cause?

comment:3 Changed 10 years ago by jbirch

Hmm.

I wonder if this is because the version from here:

 installer/Support/Web/Apache2/modules/

Which appears to be 2.0.2 is being used instead of the one that is compiled...

:)

comment:4 Changed 10 years ago by jng

Resolution: fixed
Status: newclosed

Upstaged by the installer support files again!

Note: See TracTickets for help on using tickets.