Opened 9 years ago

Closed 9 years ago

#851 closed enhancement (duplicate)

Implement multiple selection in the basic weblayout

Reported by: msuing Owned by:
Priority: high Milestone:
Component: AJAX Viewer Version: 2.0.1
Severity: major Keywords: multiple selection
Cc: External ID:

Description

The basic weblayout is still faster than the flexible weblayout but its main weakness is the lack of multiple selection.

Since the information is in the XML selection set, it could be possible to parse the selection and display everything in the property panel.

I have already performed a "derivation" of the standard behaviour by modifying :

  1. ExecuteRectangleTool?() in ajaxmappane.templ to enable a multiple selection on simple click (point) and enlarge the selection buffer around the point

pt1 = ScreenToMapUnits?(x1-5, y1-5);
pt2 = ScreenToMapUnits?(x1+5, y1+5);
RequestRectSelection?(pt1.X, pt1.Y, pt2.X, pt2.Y, appending);
pt1 = ScreenToMapUnits?(x1-2, y1-2);
pt2 = ScreenToMapUnits?(x1+2, y1+2);
RequestPointSelection(pt1.X, pt1.Y, pt2.X, pt2.Y, appending);

  1. SetProperties?(count, properties) in propertyctrl.templ to open a new window with the multiple selection in the task pane.

It could be really interesting to add 2 lists for selected layers and selected objets, and to display everything like in the flexible weblayout (why not using the php code of fusion ?).

Change History (6)

comment:1 Changed 9 years ago by ksgeograf

Would it be possible for you to add those changes as diff's, so a developer can try them out?

comment:2 Changed 9 years ago by jng

The problem here is having a consistent implementation across all 3 languages.

Anything that involves custom server-side operations has this problem (because unlike fusion, PHP can't have all the goodies).

Ideally, there should be a mapagent operation for this purpose, that way the implementation can be done client-side, independent of the 3 map viewers.

comment:3 Changed 9 years ago by waltweltonlair

The description of the problem is a little unclear. The AJAX viewer (basic weblayouts) does support multiple selection via shift-Click.

Can you clarify what you mean by "multiple selection"?

comment:4 Changed 9 years ago by jng

Simply put, the property pane should be able to display the attributes of each feature in the selection set, instead of just showing the number of features selected.

This is what the fusion selection panel does right.

comment:5 Changed 9 years ago by jbirch

Milestone: 2.1

Removing milestone; nobody has accepted the ticket.

comment:6 Changed 9 years ago by jng

Resolution: duplicate
Status: newclosed

Ticket moved to #1053

Note: See TracTickets for help on using tickets.