Opened 10 years ago

Closed 9 years ago

#731 closed defect (fixed)

Shapefiles not rendering all features at varying scales.

Reported by: aford Owned by:
Priority: high Milestone: 2.1
Component: Rendering Service Version: 2.0.2
Severity: critical Keywords:
Cc: External ID:

Description

I have a MGOS 2.0.1 application running based on ESRI shapefiles. We are using Autodesk MapGuide Enterprise Studio for our layer and map creation.

Some of the shapefiles do not fully render all of their features depending on scale e.g. at start up not all the parcel polygons are drawn. If I zoom into that area the features draw. Additionally, they can be searched on and selected even though they are not displayed. There are no scale limitations or other restrictions applied to these layers. Even with all the other layers turned off less the affected layers, the problem still persists. I have also tried changing the renderer and the issue still persists.

Attachments (1)

Ticket_731.zip (679.2 KB) - added by aford 10 years ago.
Line features, image of features fully rendered in ArcView?, and image of features partially rendered in MGOS 2.0.1

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by aford

Attachment: Ticket_731.zip added

Line features, image of features fully rendered in ArcView?, and image of features partially rendered in MGOS 2.0.1

comment:1 Changed 10 years ago by zspitzer

I had a similiar problem with 2.0.1, the new release resolved this problem for me

please try with 2.0.2

comment:2 Changed 10 years ago by aford

Version: 2.0.12.0.2

I installed 2.0.2 and it did not solve the rendering issues. It did make a few more of the features render; however, not a fix. This issue spans versions 2.0.1 and 2.0.2.

comment:3 Changed 10 years ago by tomfukushima

I used the shape file and could not reproduce what you are seeing. All the features render fine. Please provide a package to this ticket and get someone else to independently verify the problem as well. Please also supply information about your setup. Thanks, Tom

comment:4 Changed 9 years ago by jbirch

Milestone: 2.1
Resolution: fixed
Status: newclosed

No additional data provided. The uploaded SHP file appears fine to me at all zoom scales.

This is likely due to the same problem I was seeing with some features not being displayed at small scales; optimized out of display by AGG renderer, which appears to have been fixed at 2.1.

Closing.

Note: See TracTickets for help on using tickets.