Opened 12 years ago

Closed 12 years ago

#6 closed defect (fixed)

geometry buffer operation fails on curvepolygon

Reported by: pagameba Owned by: tomfukushima
Priority: high Milestone: 1.2
Component: Feature Service Version: 1.1.0
Severity: major Keywords:
Cc: jbirch External ID: 916050

Description

I have some data that is correctly rendering as polygons but does not buffer correctly using the AJAX viewer buffer operation. I have dumped the WKT of the feature:

CURVEPOLYGON ((-123.94884211782004 49.168238831862574 (LINESTRINGSEGMENT (-123.94854780008535 49.168268848308159, -123.94825348198435 49.1682988640056, -123.94829573817191 49.168477224793179, -123.94888439769528 49.168417203908902, -123.94884211782004 49.168238831862574))))

Buffering this geom results in a buffer that appears to be a circle around one point in the polygon (I didn't check but I'd guess its the first coordinate).

I'm not sure what component to stick this in. There isn't anything for the Geometry API so I'm sticking it in the feature service, please reassign as appropriate.

Attachments (1)

ticket6.GIF (2.2 KB) - added by tomfukushima 12 years ago.
Example of buffering the geometry from the SDF

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by anonymous

Paul, do you have an SDF3 (or another data file that MGOS recognizes) that contains the linestring above? This may save us a step of having to create an app that uses the above.

comment:2 Changed 12 years ago by jasonbirch

Go ahead and forward the dataset Paul, with the understanding that it is only for diagnosing this problem.

comment:3 Changed 12 years ago by jbirch

Cc: jbirch added; jason.birch@… removed

comment:4 Changed 12 years ago by pagameba

Anonymous Bob (?) should learn to log into Trac!!!

With permission from Jason, you can download the file (temporarily) from:

http://www2.dmsolutions.ca/netbin/mapguide/ticket6.sdf (16M)

Please let me know when you have the file and I will remove it from the download site. I don't really want Jason's sdf floating around forever and I don't have the tools to extract a single feature from an SDF as a new SDF.

Changed 12 years ago by tomfukushima

Attachment: ticket6.GIF added

Example of buffering the geometry from the SDF

comment:5 Changed 12 years ago by tomfukushima

External ID: 916050

My bad, I didn't realize that I had to login last time; Trac obviously doesn't know everything.

I've got the file now. Thanks.

I found the line segment (it seems to be the top part of two joined line segments that are almost vertical) in the SDF file that seems to correspond to the geometry above, but putting a 1 meter buffer around it works fine. I have attached a picture of the buffer. What size buffer are you creating, this can affects the behavior of the buffer algorithm?

comment:6 Changed 12 years ago by tomfukushima

Owner: set to tomfukushima

comment:7 Changed 12 years ago by tomfukushima

Oh wait, I selected the wrong feature class for the layer. Let me try one of the polygon classes.

comment:8 Changed 12 years ago by tomfukushima

Ok, reproduced with the "default:assessment" layer.

comment:9 Changed 12 years ago by jbirch

Ok, no comments about my data :)

I dont think it should be curvepolygons anyway. I think that dataset is in LL, and I would have stroked any arcs on the way there; they don't tend to do well in LL.

It's probably set to curvepolygon because I chose a not-very-appropriate setting in FME.

I'd be interested in knowing if the same problem happens in a projected CS.

comment:12 Changed 12 years ago by tomfukushima

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.