Opened 11 years ago

Closed 11 years ago

#460 closed defect (fixed)

MgFeatureService.GetIdentityProperties returns wrong properties for 2nd class.

Reported by: brucedechant Owned by: brucedechant
Priority: medium Milestone: 2.0
Component: Feature Service Version: 2.0.0
Severity: minor Keywords:
Cc: External ID: 1052276

Description

The identity properties for the 1st class are always returned because of a defect in the code.

This defect is caused by the following lines of code in:

MgFeatureServiceCache::GetFeatureClassIdentityProperties?:

if (NULL != data.p && entry->GetFeatureSchemaName?() != featureSchemaName && entry->GetFeatureClassName?() != featureClassName)

The fix would be to change the 2nd && to an
:

if (NULL != data.p && (entry->GetFeatureSchemaName?() != featureSchemaName

entry->GetFeatureClassName?() != featureClassName))

Change History (2)

comment:1 Changed 11 years ago by brucedechant

Owner: set to brucedechant
Status: newassigned

comment:2 Changed 11 years ago by brucedechant

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.