Opened 11 years ago

Closed 11 years ago

#435 closed defect (fixed)

can't create join

Reported by: jrizzo Owned by:
Priority: medium Milestone: 2.0
Component: Feature Service Version: 2.0.0
Severity: major Keywords:
Cc: External ID:

Description

When I load the attached SDF file, Studio erroneously throws the error: "This current feature source has no feature classes, and cannot support joins."

Attachments (2)

Elmwood Park - RDC1 4th Floor.sdf (350.0 KB) - added by jrizzo 11 years ago.
SdfJoin.jpg (240.2 KB) - added by brucedechant 11 years ago.
SDF file joined with Access mdb.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by jrizzo

comment:1 Changed 11 years ago by brucedechant

I just created a feature source with this SDF joined to an Access mdb file. See the attached screenshot.

I could not reproduce this using the latest code which will become RC3.

Changed 11 years ago by brucedechant

Attachment: SdfJoin.jpg added

SDF file joined with Access mdb.

comment:2 Changed 11 years ago by brucedechant

Did you get the error only by creating a feature source for the SDF or when you tried to create a join?

Can you describe the exact steps you did to recreate this problem so that it can be checked?

comment:3 Changed 11 years ago by jrizzo

File->New->Load Procedure... Select the file set coordinate system to arbitrary x-y coordinates (US Survey Inches) Load Resources Open the feature source click New Join Error message: "This current feature source has no feature classes, and cannot support joins"

It's possible Studio 2008 is dropping the ball here. I don't have 2009, so I can't try that. I wonder if it could be related to the fact that I migrated my repository from 1.1

comment:4 Changed 11 years ago by brucedechant

Resolution: fixed
Status: newclosed

That explains it. I am using Studio 2009 with MGOS 2.0

I have upgraded my repository several times and have not seen this so I don't believe that is the issue.

There have been some fixes to the upcoming Studio 2009 that address feature sources and joins and this could have been fixed as a side effect to some of the other changes.

Note: See TracTickets for help on using tickets.