Opened 11 years ago

Closed 11 years ago

#425 closed defect (fixed)

DWF Viewer stops responding after 60 seconds idle when connected to server with HTTPS (SSL) connection

Reported by: ronnielouie Owned by: ronnielouie
Priority: medium Milestone: 2.0
Component: Map Agent Version:
Severity: major Keywords:
Cc: External ID: 950764.02

Description

Configure a MapGuide server (web tier) with an SSL certificate, and configure IIS/Apache to serve the MapGuide site with https.

View a map on the server using the DWF Viewer (version 7). Zoom in and pan around, noting the response rate of the application.

Leave the DWF Viewer idle for at least 60 seconds (i.e., no zooming, panning or any other activity). After waiting, try to zoom or pan the map.

Expected result: The map to be zoomed or panned with the same performance as when you first started testing it.

Actual result: Refresh status bar displays and the cursor turns to an hourglass. This state remains for between 90 and 120 seconds, then the status bar disappears and the cursor reverts to its normal state. The map does not update. Any attempt to pan or zoom will then cause the viewer to lock up.

Note: If you click REFRESH after the 60 second period, you can pan and zoom as normal. The problem is that this action resets the scale and view to the default state.

Change History (1)

comment:1 Changed 11 years ago by ronnielouie

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.