Opened 11 years ago

Closed 11 years ago

#390 closed defect (fixed)

Symbolization: Strings with incorrect op-codes do not render

Reported by: louisewatson Owned by: louisewatson
Priority: medium Milestone: 2.0
Component: Rendering Service Version: 2.0.0
Severity: major Keywords:
Cc: External ID: 1023668

Description

A string with an incorrect op-code does not render at all. There should be some feedback.

Change History (2)

comment:1 Changed 11 years ago by louisewatson

Owner: set to louisewatson
Status: newassigned

comment:2 Changed 11 years ago by louisewatson

Resolution: fixed
Status: assignedclosed

Fix was to respond to Abandonment values more intelligently. Now we continue when the problem is keInvalidArgument, keNotImplemented, keNotSupported. We Quit if we hit keNoMemory or keNoResource. We Abandon parsing if any other error condition is encountered.

In the Continue and Quit case, we display the string partially formatted. In the Abandon case, we display the entire string as if it was plain text.

Note: See TracTickets for help on using tickets.