Opened 8 months ago

Closed 8 months ago

#2742 closed defect (fixed)

Installer: Cannot proceed from IIS Configuration Settings screen on Windows 10

Reported by: jng Owned by: jng
Priority: low Milestone:
Component: Installer Version: 2.5.0
Severity: trivial Keywords:
Cc: External ID:

Description

The issue is that the launch condition for the next dialog is

MGWEB_CONFIG="IIS" AND IISVERSIONMAJOR >= "#7"

On Windows 10, IIS 10 is bundled and reports an IISVERSIONMAJOR of #10

As this is a string, it fails the >= comparison check, so one cannot proceed.

Since the versions of Windows we target and support already have a version of IIS 7 or higher, we can remove the check.

Change History (2)

comment:1 Changed 8 months ago by jng

Version: 2.5.0

Correction: We'll adjust the check to be (NOT IISVERSIONMAJOR = "#0") as these conditions still require IIS to be present, we can just safely assume that the version will be >= 7

comment:2 Changed 8 months ago by jng

Resolution: fixed
Status: newclosed

Fixed trunk (r9051), 3.1 (r9052), 3.0 (r9053), 2.6 (r9054)

Note: See TracTickets for help on using tickets.