#2736 closed defect (fixed)

Server crash when layer contains complicate symbols

Reported by: zhanga Owned by:
Priority: low Milestone: 3.1
Component: Rendering Service Version: 3.1.0
Severity: major Keywords:
Cc: External ID:

Description

The issue is with the MapGuide service and we have verified the issue exists in AIMS 2017 product. We believe the issue is related to pattern style area fill using a symbol.
---
It is a heap corruption defect. The issue is at line 1792~1814, Common\Renderers\AGGRenderer.cpp. There are minx and maxx which are double. Then we convert them to int. But in some special cases, the converted imaxx will be less than iminx. It results in some memory are corrupted in next operations. To fix the issue, we need to add a check for the values.

Attachments (1)

AGGRenderer.cpp.patch (631 bytes) - added by zhanga 12 months ago.

Download all attachments as: .zip

Change History (2)

Changed 12 months ago by zhanga

Attachment: AGGRenderer.cpp.patch added

comment:1 Changed 10 months ago by jng

Resolution: fixed
Status: newclosed

Fixed trunk (r9019, r9020, r9021), 3.1 (r9022), 3.0 (r9023), 2.6 (r9024)

Note: See TracTickets for help on using tickets.