Opened 3 years ago

Closed 14 months ago

#2556 closed defect (fixed)

Escaping single quote character for built-in search command

Reported by: tuceda Owned by: jng
Priority: low Milestone: 3.0
Component: AJAX Viewer Version: 3.0.0
Severity: minor Keywords: ajax, quote, escape, fdo, filter, 2.6backport
Cc: External ID:

Description

When user enter single quote in search texte field provided by search built-in command,an FDO exception occured:

An exception occurred in FDO component. Error occurred in Feature Source (XXX): String does not represent a valid filter. (Cause: String incorrectly formatted. , Root Cause: String incorrectly formatted. )

The single quote needs to be escaped.

See the attached file for the proposed solution.

Attachments (2)

search.aspx.patch (691 bytes) - added by tuceda 3 years ago.
Proposed solution
search.aspx.2.patch (610 bytes) - added by tuceda 3 years ago.
Proposed solution (corrected)

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by tuceda

Attachment: search.aspx.patch added

Proposed solution

Changed 3 years ago by tuceda

Attachment: search.aspx.2.patch added

Proposed solution (corrected)

comment:1 Changed 3 years ago by tuceda

First proposed solution doesn't work

comment:2 Changed 3 years ago by jng

Keywords: 2.6backport added
Milestone: 3.13.0
Owner: set to jng

comment:3 Changed 14 months ago by jng

Resolution: fixed
Status: newclosed

Fixed trunk (r9042), 3.1 (r9043), 3.0 (r9044), 2.6 (r9045)

Thanks for the patch

Note: See TracTickets for help on using tickets.