Opened 3 years ago

Closed 18 months ago

#2497 closed defect (duplicate)

Avoid bash-isms in mapguide service/run/install scripts

Reported by: jng Owned by: jng
Priority: low Milestone: 3.0
Component: General Version:
Severity: trivial Keywords:
Cc: External ID:

Description

Although bash is required to be the default shell for building MapGuide/FDO on Ubuntu, it should not be a requirement for running it.

The recently introduced service control script is known to have bash-isms. The other scripts should also be checked for bash-isms. Such bash-isms should be replaced with standard equivalents.

Change History (1)

comment:1 Changed 18 months ago by jng

Resolution: duplicate
Status: newclosed

Duplicate of #2527

Note: See TracTickets for help on using tickets.