Opened 5 years ago

Closed 5 years ago

#2034 closed enhancement (fixed)

Include cause and root cause in FDO exception messages

Reported by: jng Owned by:
Priority: low Milestone: 2.4
Component: Feature Service Version:
Severity: trivial Keywords:
Cc: External ID:

Description

#2005 improved the quality of MgFdoException? error messages, but we can do even better

When a MgFdoException? is thrown, it only captures the message of the FdoException? object, but the FdoException? class also includes a cause (FdoException::GetCause?()) root cause (FdoException::GetRootCause?()) which are lost when re-thrown as a MgFdoException?.

The default macros that throw MgFdoException? should include the cause and root causes for better quality error messages

Change History (1)

comment:1 Changed 5 years ago by jng

Resolution: fixed
Status: newclosed

Fixed trunk (r6832) and 2.4 (r6801)

Note: See TracTickets for help on using tickets.