Opened 11 years ago

Closed 11 years ago

#198 closed defect (fixed)

1.2.0 RC1 Custom Search causes error in task pane

Reported by: amorsell Owned by: tonyfang
Priority: high Milestone: 1.2
Component: AJAX Viewer Version: 1.2.0
Severity: major Keywords:
Cc: External ID: 943498

Description

Opening a web layout created in an earlier version in 1.2.0 RC1. Task pane yields:

Invalid argument(s): [1] = "const string&" The string is invalid and cannot be converted. Exception occurred in method MgUtil?.WideCharToMultiByte? at line 297 in file c:\build_bond_area\mapguide_open_source_v1.2\build_17.4\mgdev\common\foundation\System/Util?.cpp

This appears to be related to one or both of two custom search commands in the web layout. Removing the custom command definitions from the web layout eliminates the errors. Further testing reveals that starting with a new web layout and adding a custom search command to it will yield this error. The error does not occur with other types of custom commands.

Change History (6)

comment:1 Changed 11 years ago by amorsell

Summary: 1.2.0 RC1 Default Task Pane1.2.0 RC1 Custom Search causes error in task pane

comment:2 Changed 11 years ago by rexszeto

External ID: 943498

comment:3 Changed 11 years ago by rexszeto

Cannot reproduce this error with an existing Custom Search or when creating a new one.

Can you please outline any specific details/reference data to reproduce this?

comment:4 Changed 11 years ago by amorsell

If I create a new web layout in Studio 2008 Beta, add the map resource, then simply add a new Search custom command (just accept all of the defaults and don't cange anything or edit the parameters), then preview the web layout, this error occurs. This is without ever adding the custom command to a toolbar, task bar, or context menu. This error also occurs with web layouts that previously existed in the repository that haver custom search cocmmands.

comment:5 Changed 11 years ago by tonyfang

Owner: set to tonyfang

comment:6 Changed 11 years ago by tonyfang

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.