Opened 11 years ago

Closed 11 years ago

#18 closed defect (fixed)

MapAgent crashes on incomplete/incorrect FeatureService - GetClassDefinition call

Reported by: jbirch Owned by: trevorwekel
Priority: medium Milestone: 1.2
Component: Map Agent Version: 1.1.0
Severity: major Keywords:
Cc: External ID: 920237

Description

Using the MapAgent? test area (mapguide/mapagent/index.html)

In section Feature Service API

Page "GetClassDefinition?"

If I enter the class or schema incorrectly, or do not enter them at all, mapagent.exe crashes on me instead of throwing an exception.

Change History (4)

comment:1 Changed 11 years ago by tomfukushima

External ID: 920237

comment:2 Changed 11 years ago by trevorwekel

Owner: set to trevorwekel
Status: newassigned

comment:3 Changed 11 years ago by trevorwekel

Hi Jason,

Which provider were you using? I cannot reproduce this with the SDF provider.

Thanks, Trevor

comment:4 Changed 11 years ago by jbirch

Milestone: 1.2
Resolution: fixed
Status: assignedclosed

Appears to have been resolved between 1.1.0 and 1.2.0-beta1.

Loading the same dataset into 1.1.0 and 1.2.0-beta1 servers shows crashes in 1.1.0, and proper exceptions in 1.2.0-beta1.

I'm marking this resolved.

Jason

Note: See TracTickets for help on using tickets.