Ticket #1687 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

A DBXML exception happens under stress test

Reported by: hubu Owned by: hubu
Priority: medium Milestone: 2.3
Component: Resource Service Version: 2.2.0
Severity: critical Keywords: DBXML
Cc: bruce dechant External ID: 1381089

Description (last modified by brucedechant) (diff)

After create about 150 sessions, MgServer can’t create session anymore. And we will get many errors like below:

Error: An exception occurred in DB XML component.
Error: DB_RUNRECOVERY: Fatal error, run database recovery
StackTrace:
  - MgSiteServiceHandler.ProcessOperation() line 83 file SiteServiceHandler.cpp
  - MgOpCreateSession.Execute() line 109 file OpCreateSession.cpp
  - MgServerSiteService.CreateSession() line 762 file ServerSiteService.cpp
  - MgServerResourceService.CreateRepository() line 541 file ServerResourceService.cpp
  - MgSessionRepository.MgSessionRepository() line 76 file SessionRepository.cpp

This is a regression since we implemented "File-per-Session". After create 150 sessions, the DBxml is locked(hang up), because it can’t allocate memory anymore.

We need to tune DBXML configuration, reduce the log buffer and cache size for session repository.

Attachments

DBXML-fix-update.patch Download (2.7 KB) - added by hubu 4 years ago.
Fix of this defect

Change History

Changed 4 years ago by hubu

Fix of this defect

Changed 4 years ago by hubu

  • status changed from new to closed
  • resolution set to fixed

Changed 4 years ago by hubu

Fixes for trunk submitted in r5779

Changed 4 years ago by brucedechant

  • description modified (diff)

Changed 4 years ago by brucedechant

Fixed for sandbox/adsk/2.2gp r5829

Changed 4 years ago by zspitzer

Can this fix be applied to the 2.2 branch?

Changed 4 years ago by hubu

Zac, this fix is not applied to 2.2 branch. This bug is a regression introduced by fix of  http://trac.osgeo.org/mapguide/ticket/1552. As I know, on 2.2 branch, we don't have this regression.

Note: See TracTickets for help on using tickets.