Opened 8 years ago

Closed 7 years ago

#1396 closed defect (fixed)

Feature join rendering problems (possible explanation inside...)

Reported by: jng Owned by: brucedechant
Priority: high Milestone:
Component: Rendering Service Version: 2.2.0
Severity: critical Keywords: join, rendering
Cc: External ID:

Description (last modified by jng)

Attached is a sample dataset illustrating the join problem and a "fix" to the join problem

There is a SDF feature source (LPI_Data) joined to a non-spatial SQLite database (Owners), both are joined via:

Name (LPI_Data) -> LAND_TAG (Owners)

With Left Outer join and 1:1 cardinality.

When you view the layer LAND_STATUS at initial extents, several of the features are white. These features are supposed to be colored differently. As you pan and zoom in these "white" features are rendered to their proper colors and some of the colored features are "white" again.

When you view the layer LAND_STATUS_FIXED at initial extents, those "white" features are colored correctly and as you zoom in and pan around those features stay that way.

The LAND_STATUS_FIXED is sourced from a LPI_Data_Fixed feature source with the same join settings to the Owners feature source.

What is the difference between LPI_Data and LPI_Data_Fixed?

  • LPI_Data has duplicate [Name] property values.
  • LPI_Data_Fixed has no duplicate [Name] property values as these features have been merged together to form one feature (using AutoCAD Map)

My theory is that the GWS feature reader has faulty logic with regards to duplicate join values from the primary side.

In the case of LAND_STATUS it will stylize correctly for the first [Name] property value it finds, but for subsequent identical [Name] property values the stylization is skipped due to this faulty logic

In the case of LAND_STATUS_FIXED this doesn't happen because all [Name] property values are unique, so this scenario never happens.

Also attached is the schema report screenshot of LPI_Data, which should better explain what the problem is here.

Attachments (2)

JoinBug.mgp (129.7 KB) - added by jng 8 years ago.
Test dataset
LPI_Data_Schema_Report.PNG (142.9 KB) - added by jng 8 years ago.
Screenshot of schema report

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by jng

Attachment: JoinBug.mgp added

Test dataset

Changed 8 years ago by jng

Attachment: LPI_Data_Schema_Report.PNG added

Screenshot of schema report

comment:1 Changed 8 years ago by jng

Description: modified (diff)

comment:2 Changed 8 years ago by tomfukushima

Owner: set to brucedechant

comment:3 Changed 8 years ago by jng

Just to add another data point:

The sqlite database was a dump of the original MS Access database which this problematic dataset was joined to (and exhibited the same problem), so I highly doubt that it is anything to do with the Feature Source it is joined to.

comment:4 Changed 7 years ago by jng

Resolution: fixed
Status: newclosed

"Fixed" with r6333 and r6348. Fixed is in quotes because the problematic join algorithm (batch sorted block) is no longer used, so in this specific case, the issue is actually resolved.

Note: See TracTickets for help on using tickets.