Opened 9 years ago

Closed 9 years ago

#1061 closed defect (fixed)

HttpHandler's GetIdentityProperties throws an unimplemented exception

Reported by: jbirch Owned by: trevorwekel
Priority: medium Milestone: 2.1
Component: Map Agent Version: 2.1.0
Severity: major Keywords:
Cc: brucedechant External ID:

Description

Currently, calls to GETIDENTITYPROPERTIES via the mapagent fail with an exception, which in turn means that Maestro's repository validation function no longer works.

Ticket #1002 modified the way that GetIdentityProperties is implemented, to allow multiple classes to be inspected at once.

The mapguide server implementation of GetIdentityProperties used to take a single class name as a string and return a MgPropertyDefinitionCollection. It now appears to take a string collection of class names and return an MgClassDefinitionCollection.

At the same time, two "not implemented" stubs were created in the platform base, one for each the old and new signatures of GetIdentityProperties.

Unfortunately, it appears that the HttpHandler's HttpGetIdentityProperties.cpp was not updated to use the new function signature, so the use of the GetIdentityProperties operation fails with an exception.

I believe that this is the cause of the problem, but would be happy to be corrected :)

Attachments (1)

Ticket1061.patch (1.6 KB) - added by trevorwekel 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by brucedechant

Owner: set to brucedechant
Status: newassigned

You are indeed correct. The GetIdentityProperties? API in the HttpHandler? is calling the old method signature which throws a MgNotImplementedException?.

comment:2 Changed 9 years ago by brucedechant

Cc: trevorwekel added

The fix for this is to restore the original API signature that was removed with the patch for ticket 1002. Even though the HTTP API is not documented any changes to it should require an RFC.

comment:3 Changed 9 years ago by trevorwekel

Cc: brucedechant added; trevorwekel removed
Owner: changed from brucedechant to trevorwekel
Status: assignednew

Changed 9 years ago by trevorwekel

Attachment: Ticket1061.patch added

comment:4 Changed 9 years ago by trevorwekel

Status: newassigned

comment:5 Changed 9 years ago by trevorwekel

I have uploaded a patch to fix the defect. The patch updates the HTTP API to use the new C++ function signature. If Bruce is ok with the change, I will commit the change to the 2.1 branch and trunk.

comment:6 Changed 9 years ago by brucedechant

Looks good Trevor - thanks.

comment:7 Changed 9 years ago by brucedechant

Submitted to branches/2.1 r4185

Submitted to sandbox/adsk/2.1 r4187

comment:8 Changed 9 years ago by brucedechant

Resolution: fixed
Status: assignedclosed

Submitted to trunk r4198

Note: See TracTickets for help on using tickets.