Opened 9 years ago

Closed 9 years ago

#819 closed defect (fixed)

Problems in displaying postscript labels layer

Reported by: clerici Owned by: marisn
Priority: normal Milestone: 6.4.1
Component: Tcl/Tk Version: svn-releasebranch64
Keywords: Cc:
CPU: Unspecified Platform: Linux

Description

Clicking in the GIS Manager the name of a file containing labels to be displayed in postscript, an error message is displayed (see error1.png). After closing the error window, the attempt of displaying labels in the Map Display gives another error (see error2.png) and the Map Display is frozen (with grass-6.4.svn_src_snapshot_2009_11_07 and tcl/tk GUI).

As an example, I created the file archlabel containing the labels from vector archsites (str1 column) through Vector > Develop Map > Create labels (see v.label.png). Into the GIS Manager I used the 'Add poscript labels layer' button to load the file archlabel (see GISManager.png). At this point the labels can be correctly displayed, but if the name archlabel in the GIS Manager is clicked, the above mentioned error messages are emitted.

Some other less important problems seem to affect the setting panel, as for example the y offset (negative upward in the panel, and positive in v.label) or the Background color option that seems to work randomly.

A.Clerici Parma University Italy

Attachments (4)

error1.png (4.7 KB) - added by clerici 9 years ago.
error2.png (5.6 KB) - added by clerici 9 years ago.
GISManager.png (39.1 KB) - added by clerici 9 years ago.
v.label.png (31.4 KB) - added by clerici 9 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by clerici

Attachment: error1.png added

Changed 9 years ago by clerici

Attachment: error2.png added

Changed 9 years ago by clerici

Attachment: GISManager.png added

Changed 9 years ago by clerici

Attachment: v.label.png added

comment:1 Changed 9 years ago by martinl

Component: defaultTcl

comment:2 Changed 9 years ago by marisn

Owner: changed from grass-dev@… to marisn

I can confirm issue with some controls not affecting result. I will try to look into this issue (still not too soon).

I was unable to reproduce that error message part with develbranch6. Clerici, please, provide information about Your TCL/Tk version, arch, distribution.

comment:3 Changed 9 years ago by clerici

Requested informations.

The reported errors were on:
Linux Fedora Core 10
Intel Core 2 Duo P8400
tcl-8.5.3-1.fc10.i386 tk-8.5.3-5.fc10.i386
with grass-6.4.svn_src_snapshot_2009_11_07
Same errors on another PC with:
Linux Fedora Core 8
Intel Core 2 Quad
tcl 8.4 tk 8.4
with grass-6.4.0RC3 and with GRASS6.3.1svn
No errors with GRASS6.2.3svn

comment:4 Changed 9 years ago by marisn

Status: newassigned

I have commited (r40109) some enhancements to 6.5 (develbranch). Can You, please, test current 6.5 branch and report back Your test results?

comment:5 Changed 9 years ago by clerici

I downloaded 6.5 (on Linux Fedora Core 8, Intel Core 2 Quad, tcl 8.4 tk 8.4).
I did the same operations and I had the same errors (error1.png and error2.png)in clicking the name archlabel in the GIS Manager.
I have noticed that the command panel is changed (reduced) with many previous options deleted. Is this an intentional change?

comment:6 Changed 9 years ago by marisn

IMHO I have fixed this issue in r40164. Please test. I leave ticket open as it's a candidate for 6.4.0.

clerici: nex time, please, press "Details" button and paste error message and it's backtrace as a text or as a text attachment.

comment:7 Changed 9 years ago by clerici

I have updated grass6.5 (40315) and everything seems OK now. The pslabel panel is complete, the options run well, and no errors at all.

Thanks

comment:8 Changed 9 years ago by marisn

Milestone: 6.4.06.4.1
Resolution: fixed
Status: assignedclosed

PS label rendering is fixed also in 6.4.1 as of r43694. There also was an misinterpretation of label file "size" option in 6.5. r43695

If anybody really needs vector label "size" option (ability to set font size in map units), open a new bug/wish.

Note: See TracTickets for help on using tickets.