Opened 3 years ago

Closed 3 years ago

#3207 closed defect (fixed)

Create histogram of raster map fails

Reported by: hellik Owned by: grass-dev@…
Priority: blocker Milestone: 7.2.0
Component: wxGUI Version: svn-trunk
Keywords: Cc:
CPU: x86-64 Platform: MSWindows 8

Description

System Info                                                                     
GRASS version: 7.3.svn                                                          
GRASS SVN revision: r69793                                                      
Build date: 2016-11-10                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.1.2                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.14.1                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W)    
Traceback (most recent call last):
  File "C:\OSGEO4~1\apps\grass\grass-7.3.svn\gui\wxpython\ma
pdisp\frame.py", line 1158, in OnHistogramPyPlot

win = HistogramPlotFrame(parent=self, rasterList=raster)
  File "C:\OSGEO4~1\apps\grass\grass-7.3.svn\gui\wxpython\wx
plot\histogram.py", line 45, in __init__

BasePlotFrame.__init__(self, parent, size=size, **kwargs)
  File "C:\OSGEO4~1\apps\grass\grass-7.3.svn\gui\wxpython\wx
plot\base.py", line 111, in __init__

self.client = plot.PlotCanvas(self)
NameError
:

Change History (16)

comment:1 Changed 3 years ago by martinl

Is this issue valid also for 7.2.0? (milestone set for 7.2.1)

comment:2 Changed 3 years ago by martinl

I cannot reproduce this bug (fresh 7.3svn on osgeo4w). Histogramming tool is shown normally.

comment:3 in reply to:  2 Changed 3 years ago by hellik

Replying to martinl:

I cannot reproduce this bug (fresh 7.3svn on osgeo4w). Histogramming tool is shown normally.

now tested with

System Info                                                                     
GRASS version: 7.0.5                                                            
GRASS SVN Revision: 69636                                                       
Build Date: 2016-10-02                                                          
Build Platform: x86_64-w64-mingw32                                              
GDAL/OGR: 2.1.1                                                                 
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.14.1                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W)  
Traceback (most recent call last):
  File "C:\OSGEO4~1\apps\grass\grass-7.0.5\gui\wxpython\mapd
isp\frame.py", line 1067, in OnHistogramPyPlot

win = HistogramPlotFrame(parent = self, rasterList = raster)
  File "C:\OSGEO4~1\apps\grass\grass-7.0.5\gui\wxpython\wxpl
ot\histogram.py", line 43, in __init__

BasePlotFrame.__init__(self, parent, size = size, **kwargs)
  File "C:\OSGEO4~1\apps\grass\grass-7.0.5\gui\wxpython\wxpl
ot\base.py", line 92, in __init__

self.client = plot.PlotCanvas(self)
NameError
:
global name 'plot' is not defined

comment:4 in reply to:  1 Changed 3 years ago by hellik

Replying to martinl:

Is this issue valid also for 7.2.0? (milestone set for 7.2.1)

its here in OSGeo4W-GRASS version: 7.0.5 and OSGeo4W-GRASS version: 7.3.svn

so no idea which milestone to set. ;-)

comment:5 Changed 3 years ago by annakrat

I don't have any problems:

GRASS version: 7.3.svn                                                          
GRASS SVN revision: r69770                                                      
Build date: 2016-11-05                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.1.2                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.14.1                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200

Could other people test, too? That error should not really happen, is there any other error before?

comment:6 in reply to:  5 ; Changed 3 years ago by hellik

Replying to annakrat:

I don't have any problems:

GRASS version: 7.3.svn                                                          
GRASS SVN revision: r69770                                                      
Build date: 2016-11-05                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.1.2                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.14.1                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200

Could other people test, too? That error should not really happen, is there any other error before?

In my tests I'm using OSGeo4W-winGRASS,as I can see, you are using the standalone, right?

could it be the numpy issue that doesn't appear in standalone, but in the OSGeo4W version?

comment:7 in reply to:  6 Changed 3 years ago by hellik

Replying to hellik:

Replying to annakrat:

I don't have any problems:

GRASS version: 7.3.svn                                                          
GRASS SVN revision: r69770                                                      
Build date: 2016-11-05                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.1.2                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.14.1                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200

Could other people test, too? That error should not really happen, is there any other error before?

In my tests I'm using OSGeo4W-winGRASS,as I can see, you are using the standalone, right?

could it be the numpy issue that doesn't appear in standalone, but in the OSGeo4W version?

See #3057

comment:8 in reply to:  6 ; Changed 3 years ago by martinl

Replying to hellik:

In my tests I'm using OSGeo4W-winGRASS,as I can see, you are using the standalone, right?

I cannot reproduce this issue even with osgeo4w installer. Could you please test 7.2.0RC1 from experimental area? To know whether we need to postpone RC2. Thanks.

comment:9 in reply to:  8 Changed 3 years ago by hellik

Replying to martinl:

Replying to hellik:

In my tests I'm using OSGeo4W-winGRASS,as I can see, you are using the standalone, right?

I cannot reproduce this issue even with osgeo4w installer. Could you please test 7.2.0RC1 from experimental area? To know whether we need to postpone RC2. Thanks.

see https://trac.osgeo.org/grass/ticket/3057#comment:18

standalone GRASS GIS 7.2.svn works without any problems; trying it with the setup in #3057#comment:18 (standalone winGRASS pointing to the OSGeo4W-python stuff), then I get the same error as reported above.

conclusion: the numpy startup issue (#3057) and this failing are interconnected!

comment:10 in reply to:  8 Changed 3 years ago by hellik

Replying to martinl:

Replying to hellik:

In my tests I'm using OSGeo4W-winGRASS,as I can see, you are using the standalone, right?

I cannot reproduce this issue even with osgeo4w installer. Could you please test 7.2.0RC1 from experimental area? To know whether we need to postpone RC2. Thanks.

yes it's for me in the OSGeo4W-winGRASS 7.2.0RC1.

see further tests in #3057

comment:11 Changed 3 years ago by annakrat

The same as in #3094, fixed in r69797 in trunk, please test.

comment:12 in reply to:  11 Changed 3 years ago by hellik

Replying to annakrat:

The same as in #3094, fixed in r69797 in trunk, please test.

tested by

GRASS version: 7.3.svn                                                          
GRASS SVN revision: r69797                                                      
Build date: 2016-11-13                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.1.2                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.14.1                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W)

fix confirmed; closing ticket.

thanks.

comment:13 Changed 3 years ago by hellik

Resolution: fixed
Status: newclosed

comment:14 Changed 3 years ago by hellik

Resolution: fixed
Status: closedreopened

reopen, as backport needed (?).

comment:15 Changed 3 years ago by martinl

Milestone: 7.2.17.2.0
Priority: criticalblocker

comment:16 Changed 3 years ago by annakrat

Resolution: fixed
Status: reopenedclosed

Backported to 72 and 70.

Note: See TracTickets for help on using tickets.