Opened 3 years ago

Closed 3 years ago

#3078 closed enhancement (duplicate)

ps.map unicode support

Reported by: kuszinger Owned by: grass-dev@…
Priority: normal Milestone: 7.2.0
Component: Ps.map Version: 7.0.4
Keywords: codepage, utf-8 Cc:
CPU: All Platform: Unspecified

Description

ps.map currently handles latin1 (iso8859-1) codepage texts in all manners.

Regarding the international use of GRASS GIS it would be essential to widen this option to support UTF-8 encoded strings for text, labelling and so on.

Extract from present ps.map manual:

"For users wanting to use special characters (such as accented characters) it is important to note that ps.map uses ISO-8859-1 encoding. This means that your instructions file will have to be encoded in this encoding. If you normally work in a different encoding environment (such as UTF-8), you have to transform your file to the ISO-8859-1 encoding, for example by using the iconv utility:

iconv -f UTF-8 -t ISO_8859-1 utf_file > iso_file "

Change History (1)

comment:1 Changed 3 years ago by annakrat

Resolution: duplicate
Status: newclosed

Seems duplicate of #1349.

Note: See TracTickets for help on using tickets.