Opened 3 years ago

Closed 3 years ago

#2927 closed defect (fixed)

r.soils.texture gives broken results

Reported by: lrntct Owned by: grass-dev@…
Priority: critical Milestone: 7.0.4
Component: Addons Version: 7.0.1
Keywords: r.soils.texture Cc:
CPU: x86-64 Platform: Linux

Description (last modified by neteler)

Roughly half of the generated map ends with NULL values. See attached pictures. This happen at the same place with different input maps.

g.region -p
projection: 3 (Latitude-Longitude)
zone:       0
datum:      wgs84
ellipsoid:  wgs84
north:      32:43:30N
south:      14:31:30N
west:       118:22:30W
east:       86:42:30W
nsres:      0:00:30
ewres:      0:00:30
rows:       2184
cols:       3800
cells:      8299200

Attachments (1)

r.soils.texture_out.png (150.2 KB) - added by lrntct 3 years ago.
resulting texture map

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by lrntct

Attachment: r.soils.texture_out.png added

resulting texture map

comment:1 Changed 3 years ago by neteler

Description: modified (diff)
Keywords: r.soils.texture added

comment:2 Changed 3 years ago by neteler

Can you make the dataset available?

comment:3 Changed 3 years ago by gianluca

Excuse me but I can't reproduce the error, could you share dataset? Thanks

Last edited 3 years ago by gianluca (previous) (diff)

comment:5 Changed 3 years ago by gianluca

There was a bug in rows/cols counts. I've corrected the code and commited the correct files in he grass_addons repository. You should re-install the corrected r.soils.texture addon with g.extensione. If r.soils.texture works fine, please close the tiket Thank you for support, don't hesitate to report other bugs or suggestions.

Gianluca Massei

Last edited 3 years ago by gianluca (previous) (diff)

comment:6 Changed 3 years ago by gianluca

Resolution: fixed
Status: newclosed

Problem solved in r67941. Feel free to reopen if the problem persists.

Note: See TracTickets for help on using tickets.