Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#2479 closed defect (duplicate)

query raster/vector map(s) does not work with vector layers

Reported by: pvanbosgeo Owned by: grass-dev@…
Priority: normal Milestone: 7.2.0
Component: Default Version: svn-trunk
Keywords: Cc:
CPU: Unspecified Platform: Linux

Description

The query raster/vector map(s) function does not work with vector layers. Clicking anywhere on the vector layer returns nothing except the following in the command console:

Traceback (most recent call last):
  File "/usr/local/grass7/grass-7.1.svn/gui/wxpython/mapwin/
buffered.py", line 1206, in MouseActions

self.OnLeftUp(event)
  File "/usr/local/grass7/grass-7.1.svn/gui/wxpython/mapwin/
buffered.py", line 1383, in OnLeftUp

self.mapQueried.emit(x=self.mouse['end'][0],
y=self.mouse['end'][1])
  File "/usr/local/grass7/grass-7.1.svn/etc/python/grass/pyd
ispatch/signal.py", line 229, in emit

dispatcher.send(signal=self, *args, **kwargs)
  File "/usr/local/grass7/grass-7.1.svn/etc/python/grass/pyd
ispatch/dispatcher.py", line 349, in send

**named
  File "/usr/local/grass7/grass-7.1.svn/etc/python/grass/pyd
ispatch/robustapply.py", line 60, in robustApply

return receiver(*arguments, **named)
  File "/usr/local/grass7/grass-7.1.svn/gui/wxpython/mapdisp
/frame.py", line 834, in Query

self.QueryMap(east, north, qdist, rast, vect)
  File "/usr/local/grass7/grass-7.1.svn/gui/wxpython/mapdisp
/frame.py", line 872, in QueryMap

encoding=encoding)
  File "/usr/local/grass7/grass-7.1.svn/etc/python/grass/scr
ipt/vector.py", line 380, in vector_what

result = json.loads(ret, **kwargs)
  File "/usr/lib/python2.7/json/__init__.py", line 351, in
loads

return cls(encoding=encoding, **kw).decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 366, in
decode

obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 382, in
raw_decode

obj, end = self.scan_once(s, idx)
ValueError
:
Expecting , delimiter: line 1 column 28 (char 27)

Change History (4)

comment:1 Changed 5 years ago by mlennert

Resolution: duplicate
Status: newclosed

Duplicate of #2431

comment:2 Changed 5 years ago by pvanbosgeo

I had seen the bug report #2431, but wasn't sure it was the same as that bug report mentions problems when there are multiple cats per mapping unit? In my case it happens in layers with only one cat per mapping unit.

comment:3 in reply to:  2 Changed 5 years ago by mlennert

Replying to pvanbosgeo:

I had seen the bug report #2431, but wasn't sure it was the same as that bug report mentions problems when there are multiple cats per mapping unit? In my case it happens in layers with only one cat per mapping unit.

The bug seems to be a result of the fix for #2431. https://trac.osgeo.org/grass/ticket/2431#comment:6.

comment:4 Changed 3 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

Note: See TracTickets for help on using tickets.