Opened 5 years ago

Closed 2 years ago

#2255 closed defect (fixed)

g.mlist warnings for layers found in other mapsets

Reported by: pvanbosgeo Owned by: grass-dev@…
Priority: normal Milestone: 7.2.0
Component: LibRaster Version: svn-releasebranch70
Keywords: g.mlist, d.rast.leg, d.rast Cc:
CPU: Unspecified Platform: Unspecified

Description

g.mlist produces warnings for all layers in other mapsets with names matching the search pattern, even if mapset is set (which should force it to search in that mapset only)

This is on GRASS 7.1.svn (2014), in Linux (Ubuntu 13.10)

Change History (8)

comment:1 Changed 5 years ago by neteler

Not sure what the issue is... here an example:

grass71 -c ~/grassdata/nc_spm_08_grass7/user2

GRASS 7.1.svn (nc_spm_08_grass7):~ > g.mlist rast
raster map(s) available in mapset <PERMANENT>:
aspect
basin_50K
...
elev_state_500m
elevation
elevation_shade
...
zipcodes
zipcodes_dbl
GRASS 7.1.svn (nc_spm_08_grass7):~ >

# now copy over "elevation" map as found in search path to
# current mapset:
GRASS 7.1.svn (nc_spm_08_grass7):~ > g.copy rast=elevation,elevation
Copy raster <elevation@PERMANENT> to current mapset as <elevation>

# list again:
GRASS 7.1.svn (nc_spm_08_grass7):~ > g.mlist rast
raster map(s) available in mapset <user2>:
WARNING: 'cell/elevation' was found in more mapsets (also found in
         <PERMANENT>)
WARNING: Using <elevation@user2>
elevation
raster map(s) available in mapset <PERMANENT>:
aspect
basin_50K
boundary_county_500m
...
elev_state_500m
WARNING: 'cell/elevation' was found in more mapsets (also found in
         <PERMANENT>)
WARNING: Using <elevation@user2>
elevation@PERMANENT
elevation_shade
facility
...
zipcodes_dbl
GRASS 7.1.svn (nc_spm_08_grass7):~ >

GRASS 7.1.svn (nc_spm_08_grass7):~ > g.mapsets -l
Available mapsets:
PERMANENT landsat neteler user1 user2

GRASS 7.1.svn (nc_spm_08_grass7):~ > g.mapsets -p 
Accessible mapsets:
user2 PERMANENT

So it tells the user that the map "elevation" exists multiple times in the search path ("Accessible mapsets")... Guess that's how it should be.

comment:2 Changed 5 years ago by wenzeslaus

Copied from grass-dev:

$ g.mlist type=rast pattern=fireprob_rf1 mapset=Ethiopia
fireprob_rf1raster map(s) available in mapset <Ethiopia>:
WARNING: 'cell/fireprob_rf1' was found in more mapsets (also found in <Ethiopiabackup>)
WARNING: Using <fireprob_rf1 at Ethiopia>
$ g.mlist type=rast pattern=fireprob_rf1
fireprob_rf1
fireprob_rf1@Ethiopiabackup
raster map(s) available in mapset <Ethiopia>:
WARNING: 'cell/fireprob_rf1' was found in more mapsets (also found in <Ethiopiabackup>)
WARNING: Using <fireprob_rf1@Ethiopia>
raster map(s) available in mapset <Ethiopiabackup>:
WARNING: 'cell/fireprob_rf1' was found in more mapsets (also found in <Ethiopiabackup>)
WARNING: Using <fireprob_rf1@Ethiopia>

It also seems that the warning is reported multiple times and that the overall formatting is strange (e.g. the line raster map(s) available in mapset <Ethiopia>: followed by WARNING: ...).

comment:3 Changed 4 years ago by hcho

Fixed in r60261.

comment:4 Changed 4 years ago by neteler

Component: DefaultLibRaster
Keywords: g.mlist d.rast.leg added

In relbranch7 I have the same issue with d.rast.leg:

GRASS 7.0.0svn (eu_laea):~ > d.rast.leg diff
WARNING: 'cell/diff' was found in more mapsets (also found in
         <modis_lst_europe>)
WARNING: Using <diff@modis_lst_reconstructed_europe_daily>
WARNING: 'cellhd/diff' was found in more mapsets (also found in
         <modis_lst_europe>)
WARNING: Using <diff@modis_lst_reconstructed_europe_daily>
WARNING: 'cellhd/diff' was found in more mapsets (also found in
         <modis_lst_europe>)
...
(many more)

It seems to be a more generic issue.

comment:5 in reply to:  3 Changed 4 years ago by neteler

Keywords: d.rast added

Replying to hcho:

Fixed in r60261.

(backported in r61040)

Glynn posted some comments here:

http://lists.osgeo.org/pipermail/grass-dev/2014-June/069628.html

comment:6 Changed 3 years ago by neteler

Can this be closed?

comment:7 Changed 2 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

comment:8 Changed 2 years ago by neteler

Resolution: fixed
Status: newclosed
Version: unspecifiedsvn-releasebranch70

No answer, assuming that the problem is solved. Closing.

Note: See TracTickets for help on using tickets.