Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1395 closed defect (fixed)

osgf generates error compiling on Mac OS X

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: Compiling Version: svn-trunk
Keywords: osgf nviz Cc: kingchaos
CPU: OSX/Intel Platform: MacOSX

Description

I just updated from the SVN and also installed the newest frameworks. osgf fails to compile with the following error. This (I think) also causes nviz to fail to compile too.

cmb-mbp-3:grass70_dev cmbarton$ cd /Users/Shared/grass_dev/grass70_dev/lib/ogsf
cmb-mbp-3:ogsf cmbarton$ make
cc -dynamiclib -compatibility_version 7.0 -current_version 7.0 -install_name /Applications/GRASS/GRASS-7.0.app/Contents/MacOS/lib/libgrass_ogsf.7.0.svn.dylib -o /Users/Shared/grass_dev/grass70_dev/dist.i386-apple-darwin10.8.0/lib/libgrass_ogsf.7.0.svn.dylib -L/Users/Shared/grass_dev/grass70_dev/dist.i386-apple-darwin10.8.0/lib -L/Users/Shared/grass_dev/grass70_dev/dist.i386-apple-darwin10.8.0/lib -arch i386 -arch x86_64     OBJ.i386-apple-darwin10.8.0/GK2.o OBJ.i386-apple-darwin10.8.0/GP2.o OBJ.i386-apple-darwin10.8.0/GS2.o OBJ.i386-apple-darwin10.8.0/GSX.o OBJ.i386-apple-darwin10.8.0/GS_util.o OBJ.i386-apple-darwin10.8.0/GV2.o OBJ.i386-apple-darwin10.8.0/GVL2.o OBJ.i386-apple-darwin10.8.0/Gp3.o OBJ.i386-apple-darwin10.8.0/Gs3.o OBJ.i386-apple-darwin10.8.0/Gv3.o OBJ.i386-apple-darwin10.8.0/Gvl3.o OBJ.i386-apple-darwin10.8.0/gk.o OBJ.i386-apple-darwin10.8.0/gp.o OBJ.i386-apple-darwin10.8.0/gpd.o OBJ.i386-apple-darwin10.8.0/gs.o OBJ.i386-apple-darwin10.8.0/gs_bm.o OBJ.i386-apple-darwin10.8.0/gs_norms.o OBJ.i386-apple-darwin10.8.0/gs_query.o OBJ.i386-apple-darwin10.8.0/gsd_cplane.o OBJ.i386-apple-darwin10.8.0/gsd_fonts.o OBJ.i386-apple-darwin10.8.0/gsd_fringe.o OBJ.i386-apple-darwin10.8.0/gsd_img_mpeg.o OBJ.i386-apple-darwin10.8.0/gsd_img_ppm.o OBJ.i386-apple-darwin10.8.0/gsd_img_tif.o OBJ.i386-apple-darwin10.8.0/gsd_label.o OBJ.i386-apple-darwin10.8.0/gsd_legend.o OBJ.i386-apple-darwin10.8.0/gsd_objs.o OBJ.i386-apple-darwin10.8.0/gsd_prim.o OBJ.i386-apple-darwin10.8.0/gsd_surf.o OBJ.i386-apple-darwin10.8.0/gsd_views.o OBJ.i386-apple-darwin10.8.0/gsd_wire.o OBJ.i386-apple-darwin10.8.0/gsdiff.o OBJ.i386-apple-darwin10.8.0/gsdrape.o OBJ.i386-apple-darwin10.8.0/gsds.o OBJ.i386-apple-darwin10.8.0/gsget.o OBJ.i386-apple-darwin10.8.0/gv.o OBJ.i386-apple-darwin10.8.0/gv_quick.o OBJ.i386-apple-darwin10.8.0/gvd.o OBJ.i386-apple-darwin10.8.0/gvl.o OBJ.i386-apple-darwin10.8.0/gvl_calc.o OBJ.i386-apple-darwin10.8.0/gvl_calc2.o OBJ.i386-apple-darwin10.8.0/gvl_file.o OBJ.i386-apple-darwin10.8.0/gvld.o OBJ.i386-apple-darwin10.8.0/trans.o  -lgrass_bitmap.7.0.svn -lgrass_g3d.7.0.svn -lgrass_vector.7.0.svn -lgrass_raster.7.0.svn -lgrass_gis.7.0.svn   -L/Library/Frameworks/UnixImageIO.framework/unix/lib -ltiff  -framework OpenGL -framework AGL -framework ApplicationServices    
Undefined symbols:
  "_db_get_value_int", referenced from:
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
  "_db_select_value", referenced from:
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
  "_db_start_driver_open_database", referenced from:
      _Gp_load_sites_thematic in Gp3.o
  "_db_get_value_string", referenced from:
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
Undefined symbols:
  "_db_get_value_int", referenced from:
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
  "_db_select_value", referenced from:
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
  "_db_start_driver_open_database", referenced from:
      _Gp_load_sites_thematic in Gp3.o
  "_db_get_value_string", referenced from:
      _Gp_load_sites_thematic in Gp3.o
      _Gp_load_sites_thematic in Gp3.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
lipo: can't open input file: /var/folders/AK/AKpYwDw1EoWI+fFF02nvRk+++TI/-Tmp-//ccAxZpeP.out (No such file or directory)
make: *** [/Users/Shared/grass_dev/grass70_dev/dist.i386-apple-darwin10.8.0/lib/libgrass_ogsf.7.0.svn.dylib] Error 1
cmb-mbp-3:ogsf cmbarton$ 

Change History (5)

comment:1 Changed 7 years ago by helena

I can confirm this, I get the same even after make distclean. I already emailed Martin as it appears to be related to the recent addition of the thematic display of point data (which will be most welcome).

Helena

comment:2 Changed 7 years ago by cmbarton

I saw a recent note from Anna that said she was having trouble with thematic points and decided to finish other tasks first. This is fine, but the broken points display shoul be commented out/deactivated until it can be fixed because it breaks all the rest of nviz.

comment:3 in reply to:  1 ; Changed 7 years ago by mmetz

Replying to helena:

I can confirm this, I get the same even after make distclean. I already emailed Martin as it appears to be related to the recent addition of the thematic display of point data (which will be most welcome).

Please try r46837.

Markus M

comment:4 in reply to:  3 Changed 7 years ago by helena

Resolution: fixed
Status: newclosed

that fixed it - it works now.

Helena

Replying to mmetz:

Replying to helena:

I can confirm this, I get the same even after make distclean. I already emailed Martin as it appears to be related to the recent addition of the thematic display of point data (which will be most welcome).

Please try r46837.

Markus M

comment:5 Changed 7 years ago by cmbarton

I can also confirm that this works and fixes the osgf error in compiling. Thanks much for the really quick fix!

Michael

Note: See TracTickets for help on using tickets.