Opened 5 years ago

Closed 4 years ago

#631 closed defect (duplicate)

make check fails on centos 6

Reported by: krudahl Owned by: pramsey
Priority: major Milestone:
Component: Build/Install Version: 3.3.8
Severity: Unassigned Keywords:
Cc:

Description

A new ./configure, make, make check fails on both 3.2.3 and 3.3.8

I have full copies of the configure and make log files if you would like. The make check fails with:

Scaler: offsetX,Y: 0,0 scaleFactor: 1e+09 ReScaler?: offsetX,Y: 0,0 scaleFactor: 1e+09 lt-XMLTester: GeometryComponentFilter?.cpp:35: virtual void geos::geom::GeometryComponentFilter::filter_ro(const geos::geom::Geometry*): Assertion `0' failed. ./testrunner: line 1: 23096 Aborted (core dumped) ./XMLTester -v ./tests/testLeaksBig.xml ./tests/split.xml ./tests/hexwkb.xml ./tests/test.xml ./tests/linemerge.xml ./tests/TestIsValid.xml ./tests/robustness.xml ./tests/buffer.xml ./tests/test.xml ./tests/singlesidedbuffer.xml ./tests/bug176.xml ./tests/bug188.xml ./tests/bug244.xml ./tests/bug275.xml ./tests/general/TestBoundary.xml ./tests/general/TestBuffer.xml ./tests/general/TestBufferMitredJoin.xml ./tests/general/TestCentroid.xml ./tests/general/TestConvexHull.xml ./tests/general/TestConvexHull-big.xml ./tests/general/TestFunctionAAPrec.xml ./tests/general/TestFunctionAA.xml ./tests/general/TestFunctionLAPrec.xml ./tests/general/TestFunctionLA.xml ./tests/general/TestFunctionLLPrec.xml ./tests/general/TestFunctionLL.xml ./tests/general/TestFunctionPA.xml ./tests/general/TestFunctionPLPrec.xml ./tests/general/TestFunctionPL.xml ./tests/general/TestFunctionPP.xml ./tests/general/TestInteriorPoint.xml ./tests/general/TestRectanglePredicate.xml ./tests/general/TestRelateAA.xml ./tests/general/TestRelateLA.xml ./tests/general/TestRelateLL.xml ./tests/general/TestRelatePL.xml ./tests/general/TestRelateAC.xml ./tests/general/TestRelateLC.xml ./tests/general/TestRelatePA.xml ./tests/general/TestRelatePP.xml ./tests/general/TestSimple.xml ./tests/general/TestValid.xml ./tests/general/TestValid2.xml ./tests/general/TestValid2-big.xml ./tests/general/TestWithinDistance.xml ./tests/stmlf/stmlf-cases-20061020.xml ./tests/stmlf/stmlf-cases-20070119.xml ./tests/robust/TestRobustOverlayFixed.xml ./tests/robust/TestRobustRelate.xml ./tests/fme.xml ./tests/TestBufferExternal.xml ./tests/TestBufferExternal2.xml ./tests/heisenbugs.xml ./tests/badguy3.xml ./tests/hole_from_shell.xml ./tests/hole_red.xml ./tests/safe/16595.xml ./tests/safe/16596.xml make[3]: * [check-TESTS] Error 1 make[2]: * [check-am] Error 2 make[1]: * [check-recursive] Error 1 make: * [check-recursive] Error 1

Attachments (1)

makefail.tgz (35.5 KB) - added by krudahl 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by krudahl

Attachment: makefail.tgz added

comment:1 Changed 5 years ago by strk

Any warning at compile time ?

comment:2 Changed 5 years ago by strk

Resolution: invalid
Status: newclosed

3 months without feedback turns this into an invalid report...

comment:3 Changed 4 years ago by Mike Toews

Resolution: invalid
Status: closedreopened

Changing resolution as duplicate of #535 ...

comment:4 Changed 4 years ago by Mike Toews

Resolution: duplicate
Status: reopenedclosed

Duplicate of #535

Note: See TracTickets for help on using tickets.