Ticket #507 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Postgres crash in geos 3.3.0 using postgis st_buffer function

Reported by: luisico Owned by: geos-devel@…
Priority: minor Milestone: 3.3.4
Component: Default Version: 3.3.0
Severity: Critical Keywords:
Cc:

Description

Hi, I have a postgresql server with postgis running on Ubuntu 10.04. The postgresql version is 9.1.2-1~lucid and this is the postgis_full_version():

POSTGIS="2.0.0SVN" GEOS="3.3.0-CAPI-1.6.1" PROJ="Rel. 4.7.1, 23 September 2009" GDAL="GDAL 1.8.0, released 2011/01/12" LIBXML="2.7.6" USE_STATS

The postgresql server crashes when I run the next query:

SELECT st_simplifypreservetopology(st_multi(st_buffer(st_buffer(st_buffer(the_geom,-0.09),0.18),-0.08)),0.05) FROM gadm0 WHERE iso='IDN';

Even enabling high postgres debug levels it doesn't give any clue about the problem. It just says the next:  http://pastie.org/3304257

I enabled the core dumps and this is what I got:  http://pastie.org/3304135

Please, let me know if I can provide more information. Thanks

Change History

Changed 3 years ago by strk

Did you try upgrading to GEOS 3.3.2 ?

Changed 3 years ago by strk

  • milestone changed from 3.3.3 to 3.3.4

Changed 3 years ago by strk

luisico: can you provide a dump or shapefile of the gadm0 table ?

Changed 3 years ago by strk

  • status changed from new to closed
  • resolution set to duplicate

I think this is a duplicate of #473, which got fixed in 3.3.2

Note: See TracTickets for help on using tickets.