Opened 9 years ago

Closed 9 years ago

#330 closed defect (fixed)

cmake puts geos_c.h into include/geos

Reported by: Mike Toews Owned by: mloskot
Priority: minor Milestone:
Component: Build/Install Version: master
Severity: Annoyance Keywords: cmake
Cc:

Description

Testing the latest SVN, CMake installs geos_c.h into include/geos rather than in include (as with previous versions <=3.2). However, the header file still refers to children header files in a geos subdirectory, e.g.:

#include <geos/export.h>

and the configuration utility points where it should, but there is not header file there:

$ geos-config --includes
/usr/local/include

This gives errors and grief for configuring PostGIS. The quick-fix is:

mv geos_c.h ..

... but this is still a defect due to manual intervention for the install.

Other info:

$ cmake --version
cmake version 2.6-patch 0
$ g++ --version
g++ (Debian 4.3.2-1.1) 4.3.2

Change History (6)

comment:1 Changed 9 years ago by pmeems

We've got the same issue when compiling MapWindow? GIS with GEOS. It would be better/nice to have all include files in the same place. After compiling GEOS we move all include files to a common include folder and that is working for all libraries (GDAL, etc) we use except for this file. Thanks.

comment:2 Changed 9 years ago by strk

Component: DefaultBuild/Install
Owner: changed from geos-devel@… to mloskot

Confirmed.

comment:3 Changed 9 years ago by Mike Toews

Keywords: cmake added

comment:4 Changed 9 years ago by mloskot

Status: newassigned

comment:5 Changed 9 years ago by mloskot

Fixed in trunk r2912

comment:6 Changed 9 years ago by mloskot

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.