Opened 8 years ago

Closed 8 years ago

#282 closed defect (fixed)

Can't compile geos trunk under mingW

Reported by: robe Owned by: pramsey
Priority: major Milestone: 3.2.0
Component: Build/Install Version: master
Severity: Unassigned Keywords:
Cc:

Description

I thought MingW compile was fixed though I suppose it may have been and is now broken again. I can still compile the 3.1.1 release version, though I think I can't compile 3.1 branch SVN, but will need to double check that one.

I confirmed with someone else running MingW that he has the same issue. Also using newer 4.4.0 gcc gives same error.

from IndexedPointInAreaLocator?.cpp:17: c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/c++/3.4.5/cwchar:161: error: `::swprintf' has not been declared c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/c++/3.4.5/cwchar:168: error: `::vswprintf' has not been declared make[4]: * [IndexedPointInAreaLocator?.lo] Error 1 make[4]: Leaving directory `/c/thesrc/geos_trunk/source/algorithm/locate' make[3]: * [all-recursive] Error 1 make[3]: Leaving directory `/c/thesrc/geos_trunk/source/algorithm/locate' make[2]: * [all-recursive] Error 1 make[2]: Leaving directory `/c/thesrc/geos_trunk/source/algorithm' make[1]: * [all-recursive] Error 1 make[1]: Leaving directory `/c/thesrc/geos_trunk/source'

Change History (4)

comment:1 Changed 8 years ago by robe

Same issue with Geos 3.1 branch

from IndexedPointInAreaLocator.cpp:18:
c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/c++/3.4.5/cwchar:161: error: `::swprintf' has not been declared
c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/c++/3.4.5/cwchar:168: error: `::vswprintf' has not been declared
make[4]: *** [IndexedPointInAreaLocator.lo] Error 1
make[4]: Leaving directory `/c/thesrc/geos3.1/source/algorithm/locate'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/c/thesrc/geos3.1/source/algorithm/locate'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/c/thesrc/geos3.1/source/algorithm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/c/thesrc/geos3.1/source'
make: *** [all-recursive] Error 1


comment:2 Changed 8 years ago by sanak

robe,

I think that the cause seems to be the latest MinGW bug.

Please see the following archive for details.

http://lists.osgeo.org/pipermail/geos-devel/2009-June/004240.html

Regards,

comment:3 Changed 8 years ago by robe

Sanak,

Thanks -- yes commenting out those lines does seem to get me much further.

Seems to be the same issue under 4.4.0 by the way since I have the same issue on this box running 4.40.

How come the tagged 3.1.1 compiles fine without these changes though?

I still have issues under GCC 4.4.0

Getting a g++.exe: c:/MinGW/lib/gcc/mingw32/4.4.0/libstdc++.dll.a: No such file or directory

But that sounds more like I'm just missing a file.

Regina

comment:4 Changed 8 years ago by robe

Resolution: fixed
Status: newclosed

I guess these are all MingW issues. Was able to fix the last issue by editing C:\MinGW\lib\gcc\mingw32\4.4.0\libstdc++.la

and changing library_names='libstdc++.dll.a'

to #library_names='libstdc++.dll.a' library_names='libstdc++.a'

As alluded to here http://www.nabble.com/GCC-4.4.0-fails-with-GMP-td24191439.html

Yet to see if my PostGIS install is happy with this :)

Note: See TracTickets for help on using tickets.