Ticket #177 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Proxy authentication not working with WxS harvesting

Reported by: dwyera Owned by: simonp
Priority: minor Milestone:
Component: General Version: v2.4.2
Keywords: Cc: andrew.dwyer@…

Description

GeoNetwork 2.4.2 doesn't use the user supplied proxy credentials for WxS harvesting. GeoNetwork is sending it's requests through the specified proxy but doesn't appear to be supplying the credentials.

This bug was identified using both Tomcat 6 and Jetty running on Windows Server 2003.

I have reported this bug on the user forums.  http://n2.nabble.com/Proxy-authentication-with-W-S-harvesting-SEC-UNCLASSIFIED-td3936188.html

Attachments

proxy_auth.diff Download (2.3 KB) - added by dwyera 5 years ago.

Change History

follow-up: ↓ 2   Changed 5 years ago by simonp

  • owner changed from geonetwork-devel@… to simonp

Hi Andrew,

Try applying the changes in svn commit 5588 - sometimes the credentials were not actually being used.

Cheers, Simon

in reply to: ↑ 1   Changed 5 years ago by dwyera

Replying to simonp:

Hi Simon,

I tried your change but found one small problem. GeoNetwork now sends the proxy credentials but attempts to use NTLM authentication (because the proxy I'm using supports it) and fails with an exception. The problem is that according to the  apache documentation, some changes need to be made to the code to support NTLM, I.e. the use of the  UsernamePasswordCredentials class needs to be replaced with  NTCredentials.

The way I've fixed the problem for my version is to instruct HttpClient? not to use NTLM, which means the client should fall back to Basic or Digest authentication. The alternative would be to replace  UsernamePasswordCredentials with  NTCredentials.

I've attached my changes in a diff file.

Thanks for your help

Andrew

Changed 5 years ago by dwyera

  Changed 5 years ago by simonp

Thanks Andrew! I'll commit this in early January as I haven't had a chance to test it fully.

  Changed 5 years ago by simonp

  • status changed from new to closed
  • resolution set to fixed

Applied in svn rev 5861

Note: See TracTickets for help on using tickets.