Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#7231 closed defect (fixed)

LIBKML driver on Windows doesn't properly detect x, y, z coordinates

Reported by: annakrat Owned by: warmerdam
Priority: normal Milestone: 2.2.4
Component: OGR_SF Version: 2.2.3
Severity: normal Keywords: libkml
Cc:

Description

On Windows 10, LIBKML doesn't properly read xyz coordinates probably due to whitespace.

From Even Rouault:

From testing, it appears that the presence of newline+tabulations without spaces between coordinate triplets is the cause of the issue, where libkml doesn't detect properly the start of the x coordinate of the new triplet and mangles it with the z of the previous one.

I attached a file for testing.

Attachments (1)

flight1.kml (1.1 KB) - added by annakrat 6 months ago.
kml for testing

Download all attachments as: .zip

Change History (4)

Changed 6 months ago by annakrat

Attachment: flight1.kml added

kml for testing

comment:1 Changed 6 months ago by Even Rouault

Resolution: fixed
Status: newclosed

In 41418:

LIBKML: workaround Windows specific issue with libkml (at least the version used by OSGeo4W at time of writing), where tabulations as coordinate separators aren't properly handled (fixes #7231)

comment:2 Changed 6 months ago by Even Rouault

In 41419:

LIBKML: workaround Windows specific issue with libkml (at least the version used by OSGeo4W at time of writing), where tabulations as coordinate separators aren't properly handled (fixes #7231)

comment:3 Changed 6 months ago by Even Rouault

Milestone: 2.2.4
Note: See TracTickets for help on using tickets.