Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#6996 closed defect (fixed)

GdalOpen crash on c# if the dataset doesn't support SetNoDataValue (with PAM not enabled)

Reported by: aghariani Owned by: warmerdam
Priority: normal Milestone: 2.2.2
Component: default Version: svn-trunk
Severity: normal Keywords:
Cc:

Description

With GDAL_PAM_ENABLED=NO

On c++: GDALOpen("egm96_15.gtx", GA_ReadOnly); Will display a warning (Error 6: SetNoDataValue?() not supported for this dataset) but will not crash.

On c#: Gdal.OpenShared?("egm96_15.gtx", Access.GA_ReadOnly); Will crash right away.

As it is now, I am unable to open gtx files on c#. This is linked to ticket #4660 which added a poBand->SetNoDataValue?( -88.8888 );

This modification on the gtx driver is the cause of the crash.

Change History (3)

comment:1 Changed 2 months ago by Even Rouault

Resolution: fixed
Status: newclosed

In 39790:

GTX: do not emit error when opening with GDAL_PAM_ENABLED=NO (fixes #6996)

comment:2 Changed 2 months ago by Even Rouault

In 39791:

GTX: do not emit error when opening with GDAL_PAM_ENABLED=NO (fixes #6996)

comment:3 Changed 2 months ago by Even Rouault

Milestone: 2.2.2
Note: See TracTickets for help on using tickets.