Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#6929 closed defect (fixed)

ENVISAT: wrong member initialization in MerisL2FlagBand

Reported by: Even Rouault Owned by: warmerdam
Priority: normal Milestone: 2.2.1
Component: default Version: 2.2.0
Severity: normal Keywords:
Cc:

Description

r35218 changed the way nRecordSize, nDataSize and pReadBuf in a wrong way, since nBlockXSize is only properly set in the constructor body.

Change History (2)

comment:1 Changed 6 months ago by Even Rouault

Resolution: fixed
Status: newclosed

In 39168:

ENVISAT: fix 2.2 regression in initialization of members of MerisL2FlagBand. Spotted by -fsanitize=undefined,unsigned-integer-overflow since nBlockXSize is initialized to -1. Fixes #6929

comment:2 Changed 6 months ago by Even Rouault

In 39169:

ENVISAT: fix 2.2 regression in initialization of members of MerisL2FlagBand. Spotted by -fsanitize=undefined,unsigned-integer-overflow since nBlockXSize is initialized to -1. Fixes #6929

Note: See TracTickets for help on using tickets.