Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#6869 closed defect (fixed)

Crash with gdalwarp -multi with RPC_DEM

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 2.1.4
Component: Algorithms Version: 2.1.0
Severity: normal Keywords: warp
Cc:

Description

Reported as https://lists.osgeo.org/pipermail/gdal-dev/2017-April/046489.html

"""

I've run into issues using gdalwarp for an RPC ortho. My input GeoTiff? file contains the required information in the RPC metadata domain, and the command runs fine under the GDAL 2.1.0 command line utility (windows 7, 64-bit):

gdalwarp -multi -tap -et 0.0 -r cubic -srcnodata 0 -rpc -overwrite -to "RPC_DEM_INTERPOLATION=CUBIC" -to "RPC_DEM_MISSING_VALUE=0" -to "RPC_DEM=D:\Temp\bug_gdalwarp\DEM.tif" -tr 30 30 -t_srs "+proj=aea +lat_1=44.75 +lat_2=55.75 +lat_0=40 +lon_0=-96 +x_0=0 +y_0=0 +ellps=WGS84 +datum=WGS84 +units=m +no_defs" D:\Temp\bug_gdalwarp\IMG.tif D:\Temp\bug_gdalwarp\IMG_ortho.tif

However, the same command and inputs fail under GDAL 2.1.3, without error messages, after getting to about 20% on the progress bar. It simply pops up the usual window saying "gdalwarp.exe has stopped working. A problem caused the program to stop working correctly"...

Strangely, it only crashes for some images, while some are OK. I haven't been able to pinpoint the cause. """

Change History (4)

comment:1 Changed 3 months ago by Even Rouault

Resolution: fixed
Status: assignedclosed

In 38092:

gdalwarp: fix crash when -multi and -to RPC_DEM are used together (fixes #6869)

comment:2 Changed 3 months ago by Even Rouault

In 38093:

gdalwarp: fix crash when -multi and -to RPC_DEM are used together (fixes #6869)

comment:3 Changed 3 months ago by Even Rouault

In 38094:

gdalwarp: fix crash when -multi and -to RPC_DEM are used together (fixes #6869)

comment:4 Changed 3 months ago by Even Rouault

Milestone: 2.1.4
Version: unspecified2.1.0
Note: See TracTickets for help on using tickets.