Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#6740 closed defect (fixed)

spatialite: confusing layers listed

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 2.1.3
Component: OGR_SF Version: unspecified
Severity: normal Keywords: spatialite view
Cc:

Description

ogrinfo /home/even/mapserver/mapserver/msautotest/wxs/data/db.sqlite

reports

INFO: Open of `/home/even/mapserver/mapserver/msautotest/wxs/data/db.sqlite'
      using driver `SQLite' successful.
1: towns (Point)
2: towns_with_null (Point)
3: myview (Point)
4: towns(geometry) (Point)

The last layer "towns(geometry)" is a duplicate of the first one. It is instanciated for the needs of the "myview" layer that needs to find the underlying table layer. But "towns(geometry)" shouldn't appear in visible layers and should remain a technical one.

Change History (2)

comment:1 Changed 12 months ago by Even Rouault

Resolution: fixed
Status: newclosed

In 36599:

Spatialite: avoid spatial views to cause layers 'layer_name(geometry_name)' to be publicly listed (fixes #6740)

comment:2 Changed 12 months ago by Even Rouault

In 36600:

Spatialite: avoid spatial views to cause layers 'layer_name(geometry_name)' to be publicly listed (fixes #6740)

Note: See TracTickets for help on using tickets.