Opened 14 years ago

Closed 7 years ago

#672 closed defect (wontfix)

gdal_merge.py failes on ~20 "Aster relative DEM" HDF files

Reported by: tutey@… Owned by: dron
Priority: high Milestone:
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: hdf
Cc: Mateusz Łoskot

Description (last modified by Mateusz Łoskot)

If I try to merge more than ~20 "Aster relative DEM" HDF files (obtained from http://edcimswww.cr.usgs.gov/pub/imswelcome/) an error occures:

[ziutek@localhost ziutek]$ gdal_merge.py -o /home/ziutek/aster.tif -of GTiff -n -150 /mnt/windows/gisdane/aster/dupa/*.hdf
ERROR 2: CPLMalloc(): Out of memory allocating -4 bytes.

Maybe it is related to the http://208.24.120.44/show_bug.cgi?id=671.

Change History (2)

comment:1 Changed 10 years ago by Mateusz Łoskot

Cc: Mateusz Łoskot added
Description: modified (diff)
Keywords: hdf added

comment:2 Changed 7 years ago by Even Rouault

Resolution: wontfix
Status: newclosed

The link to the samples that failed is broken. So not able to reproduce. Closing. Reopen if it is still current

Note: See TracTickets for help on using tickets.