Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#6718 closed defect (fixed)

GDAL DODS driver crashes on URL that are not DODS servers

Reported by: Even Rouault Owned by: warmerdam
Priority: normal Milestone: 2.1.3
Component: default Version: unspecified
Severity: normal Keywords:
Cc:

Change History (4)

comment:1 Changed 20 months ago by Even Rouault

Resolution: fixed
Status: newclosed

In 36174:

DODS: fix crash on URL that are not DODS servers (fixes #6718)

comment:2 Changed 20 months ago by Even Rouault

In 36175:

DODS: fix crash on URL that are not DODS servers (fixes #6718)

comment:3 Changed 20 months ago by Even Rouault

Milestone: 2.1.3

comment:4 Changed 20 months ago by Kurt Schwehr

Some extra context since I already have it.

This was easily reproducible without python using gdalinfo.

A sample stack trace of the segfault on ubuntu 14.04:

Error: Failed to load processor bash
No macro or processor named 'bash' found

The segfault gone.

Error: Failed to load processor bash
No macro or processor named 'bash' found
Note: See TracTickets for help on using tickets.