Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#6681 closed defect (fixed)

GDAL_DISABLE_READDIR_ON_OPEN masks CPL_VSIL_CURL_ALLOWED_EXTENSIONS

Reported by: mojodna Owned by: warmerdam
Priority: normal Milestone: 2.1.2
Component: default Version: 2.1.1
Severity: normal Keywords:
Cc:

Description

When GDAL_DISABLE_READDIR_ON_OPEN=TRUE, CPL_VSIL_CURL_ALLOWED_EXTENSIONS is ignored. This is reproducible when setting CPL_CURL_VERBOSE=YES and watching requests for extensions not in the list being made when running gdalinfo /vsicurl/http://oam-dynamic-tiler-tmp.s3.amazonaws.com/sources/57fc935b84ae75bb00ec751b/index.vrt.

(Since it's S3, it doesn't support directory listing, so it makes sense to turn off.)

Change History (3)

comment:1 Changed 4 months ago by Even Rouault

Resolution: fixed
Status: newclosed

In 35716:

/vsicurl/: take CPL_VSIL_CURL_ALLOWED_EXTENSIONS into account even if GDAL_DISABLE_READDIR_ON_OPEN is defined (fixes #6681)

comment:2 Changed 4 months ago by Even Rouault

In 35717:

/vsicurl/: take CPL_VSIL_CURL_ALLOWED_EXTENSIONS into account even if GDAL_DISABLE_READDIR_ON_OPEN is defined (fixes #6681)

comment:3 Changed 4 months ago by Even Rouault

Milestone: 2.1.2
Note: See TracTickets for help on using tickets.