#6430 closed defect (fixed)

[2.0 regression] Build error in JPEGLS driver

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 2.0.3
Component: default Version: 2.0.0
Severity: normal Keywords:
Cc:

Description

[18:53] <HotShot> Even: just built the 2.0.2 release from source. in frms/jpegls/jpeglsdataset.cpp line 556, compilation fails. "eErr = poSrcDS->s(GF_Read,"
[18:53] <HotShot> s is unknown.
[18:54] <HotShot> Judging from older releases and comparison with other drivers, looks like this should be "RasterIO" instead of "s", or seomething along these lines.
[18:55] <EvenR> HotShot: yes
[18:56] <HotShot> I just finished compiling after replacing s with RasterIO, jpegls driver appears functional now. Not sure why the change from older RasterIO to unknown s function.
[18:57] <EvenR> as you said, a typo that went unnoticed since building this driver is a bit adhoc

Change History (1)

comment:1 Changed 13 months ago by Even Rouault

Milestone: 2.0.3
Resolution: fixed
Status: newclosed

trunk r33831, branches/2.0 r33832 "JPEGLS: fix build error (#6430)"

Note: See TracTickets for help on using tickets.