#6346 closed enhancement (fixed)

Support for ElasticSearch 2+

Reported by: asci Owned by: warmerdam
Priority: normal Milestone: 2.0.3
Component: OGR_SF Version: unspecified
Severity: normal Keywords: elasticsearch
Cc:

Description

The ElasticSearch? driver fails to connect to ElasticSearch? 2.0 and later. This appears to be caused by the use of the _status method to check the validity of the connection.

_status was deprecated in ElasticSearch? 1.2 and removed in 2.0.

Recommend using either _stats or _recovery.

Change History (1)

comment:1 Changed 17 months ago by Even Rouault

Milestone: 2.0.3
Resolution: fixed
Status: newclosed

trunk r33328, branches/2.0 r33329 "ElasticSearch?: get /_stats instead of /_status for ElasticSearch? 2.0 compatibility (#6346)"

Note: See TracTickets for help on using tickets.