#6077 closed defect (fixed)

Add pkg-config support for libkml fork

Reported by: Bas Couwenberg Owned by: warmerdam
Priority: normal Milestone: 2.0.2
Component: default Version: 1.11.2
Severity: normal Keywords:
Cc:

Description

As discussed on gdal-dev the current m4/ax_lib_libkml.m4 doesn't detect the new libkml because it still expects the thirdparty boost headers.

The attached patch add pkg-config support for libkml as used by the libkml fork. It falls back to the old manual method if no suitable version is found with pkg-config.

Attachments (1)

libkml-pkgconfig.patch (16.0 KB) - added by Bas Couwenberg 20 months ago.

Download all attachments as: .zip

Change History (7)

Changed 20 months ago by Bas Couwenberg

Attachment: libkml-pkgconfig.patch added

comment:1 Changed 19 months ago by Even Rouault

trunk r29715 "Add pkg-config support for libkml fork, in addition to the old detection method. The libkml/libkml fork on GitHub? supports pkg-config and no longer includes the third_partry libraries. (patch by Bas Couwenberg, #6077)"

comment:2 Changed 19 months ago by Even Rouault

Bas, there are issues when regenerating configure if the /usr/share/aclocal/pkg.m4 file is not there (I have had this issue since I'm using automake/autoconf compiled manually, the ones of my system being obsolete). This file is installed by pkg-config and expands PKG_PROG_PKG_CONFIG. If it is not there, the resulting configure is corrupted. This is what happened on http://debbie.postgis.net:8080/job/GDAL_Trunk/3030/console

./configure: line 24715: syntax error near unexpected token `0.25'
./configure: line 24715: `                PKG_PROG_PKG_CONFIG(0.25) # check and set $PKG_CONFIG'
GNUmakefile:2: GDALmake.opt: No such file or directory
make: *** No rule to make target `config.status', needed by `GDALmake.opt'.  Stop.
Build step 'Execute shell' marked build as failure
IRC notifier plugin: Sending notification to: #postgis
Warning: you have no plugins providing access control for builds, so falling back to legacy behavior of permitting any downstream builds to be triggered
Finished: FAILURE

Any idea if that could be improved ? Perhaps copying pkg.m4 to GDAL m4 directory ?

comment:3 Changed 19 months ago by Even Rouault

Milestone: 1.11.32.1.0

Doesn't look like 1.11.3 material, especially with the m4 / PKG_PROG_PKG_CONFIG issue. Moving milestone

comment:4 in reply to:  2 Changed 19 months ago by Bas Couwenberg

Replying to rouault:

Perhaps copying pkg.m4 to GDAL m4 directory ?

I guess that's the best option if you cannot rely on the system providing a suitable pkg-config.

Unfortunately I cannot access the debbie link to get a better idea of what's going on, and I so far cannot reproduce the problem.

comment:5 Changed 19 months ago by Even Rouault

trunk r30554 "Add m4/pkg.m4 and regenerate aclocal.m4 (#6077)"

branches/2.0 r30555 "Add pkg-config support for libkml fork, in addition to the old detection method. The libkml/libkml fork on GitHub? supports pkg-config and no longer includes the third_partry libraries. (patch by Bas Couwenberg, #6077)"

comment:6 Changed 18 months ago by Even Rouault

Milestone: 2.1.02.0.2
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.